Mozilla changes Windows keyboard mapping (weird but true)

VERIFIED DUPLICATE of bug 80274

Status

MailNews Core
Internationalization
--
major
VERIFIED DUPLICATE of bug 80274
17 years ago
10 years ago

People

(Reporter: Jacek Piskozub, Assigned: nhottanscp)

Tracking

({regression})

Trunk
x86
Windows ME
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I use the standard English language WindowsME (the US edition) with "Polish
(programmers)" keyboard as the default. Using any Polish letter in Mozilla mail
changes "Polish (programmers)" keyboard setting to "Polish", meaning the
Right-Alt-letter for the Polish characters no longer works and even more
annoyingly the letters "y" and "z" are exchanged. 

Reproductibility: every time.

Steps to reproduce:

1. Choose Polish (programmers) as your default keyboard and email composition to
Central European (ISO-8859-2) - the default settings for Polish users of Mozilla
2. Open Mozilla 20010509
3. Start writing an email (check that you type Mozilla as Mozilla0
4. Use Right-Alt-[a s c o l z x] (one of the letters)
5. Check if you type now Mozilla as Moyilla

Actual results:

Mozilla actually changes the mapping. It shows in Control Panel -> Keyboard ->
Language as "Polish" instead of "Polish (programmers)". The visible results: "z"
exchanged with "y", Right-Alt-letter does not produce the Polish signs, they are
now accessible by keys like "; ' [ ]"

Expected results:

Using Right-Alt-a,s,c,o,l,z,x should result in writing a Polish letter. The
letters z and y are where you exectthem on an English/American keyboard. The
keyboard mapping is "Polish (programmers)".

Additional information:

orkaround: Change in Control Panel -> Keyboard -> Language -> Properties
"Polish" to "Polish (programmers)". It needs to be done only once per session
(Mozilla does not do it the second time) and luckily does not require a reboot.

It is probable that it happens with other languages that use Righ-Alt- for some
of their national characters (Czech?).

Sometimes I managed to achieve this result by just sending an email (even with
no Polish national signs)


I mark it Major as it is a big problem such the users in Poland and probably
several other countries (especially as we use the letters "y" and "z" a lot).
However, I'm afraid some of the rest of you will probably want to make it Normal
or even less :-(
(Reporter)

Comment 1

17 years ago
I'll add thatbthis is a recent regression. It did not happen prior to Mozilla
0.9, neither on trunk or the 0.9 branch.
Keywords: regression

Comment 2

17 years ago
Does this problem happen when you type in URL bar?
(Reporter)

Comment 3

17 years ago
Typing in URL field. Well, I'm not sure whether I undrstand you. The answer
depends on what you are actually asking.

- No, as URLs should not use national characters like ????ó???. That's why I did
not test it. It isnot possible to ht this bug in normal use by typing (for
example) Ctr-Alt-a in the URL field as there are no URL using such characters.

- Yes, *after* the keyboard mapping is changed, it happens in every window and
application, including Mozilla URL field.

Actually I have problems repoducing the error on a different machine (same
WimME, same keyboard settings, same Mozilla settings0 using 2001050910 and all
later builds do not work at all (crashes while reading mail or starting Mozilla
not related to this bug). I'll check in a few minutes if the same build
2001050905 I used on the original host will reproduce the bug here.

Comment 4

17 years ago
Thanks. What I'm suspecting is that it could be a browser generic problem, not 
only limited to mail composition window. 
If that's true, it could happen on some other widgets, like URL bar, or search 
field on http://home.netscape.com. Could you try the same steps on the search 
field on http://home.netscape.com? 

Comment 5

17 years ago
When this happens on mail composition window, does it happen in subject field or 
 mail body area? Could you please try it on HTML composer too? Thanks.
(Reporter)

Comment 6

17 years ago
I cannot repoduce the error at all with the other almost identical PC (same OS,
same settings, same Mozilla). It's highly frustrating.

I'll try widgets, search window, URL bar in the afternoon on the original PC
with this problem.  

BTW, I've never seen an applcation change the Windows keyboard language settings
- working on a similar setups (Enlish windows, Polish programmers keyboard) for
the last 6 years.
(Reporter)

Comment 7

17 years ago
I could not get this effect with URL fields, search windows etc. Sending myself
an email with some Central European characters made the difference. Atually,
contrary to my "steps to reproduce", this time the swich happened not exactly at
the moment of entering the message text, rather around receiving it (I kept
typing "z" every few seconds in a notepad window to catch the moment).  

Comment 8

17 years ago
Did you say that after you received the mail which was typed using "Polish
(programmers)" keyboard, the keyboard mapping has changed to "Polish"?
(Reporter)

Comment 9

17 years ago
Yes, and this is the reason for "weird" in the subject. 

I now know that just reading the offending message is enough to change the
keyboard setting. I'll attch the message.

Mozilla, it seems does not change anything I can find in the registry, but
Control Panel |Keyboard | Languages shows the wrong setting just after reading
the message. Why? I believe the reason is I have two entries in the registry:

[HKEY_CURRENT_USER\keyboard layout\preload\1]
@="00000415"

(this is "Polish") and 

[HKEY_USERS\.DEFAULT\keyboard layout\preload\1]
@="00010415"

This is "Polish programmers".

It seems Mozilla reads the former and this changes something in the system. I
know they should be probably the same and this could be more an error of
WindowsME than Mozilla but how many users will be able to find and correct this?
(Reporter)

Comment 10

17 years ago
Created attachment 34024 [details]
The message that changes keyboard settings (once per session)
(Reporter)

Comment 11

17 years ago
After more tests I am convinced that the registry setting
[HKEY_CURRENT_USER\keyboard layout\preload\1]
@="00000415"
together with another I skipped before:
[HKEY_CURRENT_USER\keyboard layout\substitutes\00000415]
@="00010415"
are OK, that is they make sure the system knows it should use 00010415, not
00000415.

Does Mozilla access the first somehow, ignoring the second and as a result makes
the system believe it should use 00000415 as the keyboard setting?
(Reporter)

Comment 12

17 years ago
Well, after some more tests with 2001051104 build, I decided that you are right,
it is not a mailnews bug. I can reproduce it now without opening the mail
window. It's possible that touching the URL field (or other text field) is
necessary. 

I will probably close down this bug and open another (to decrease the spam factor).
(Reporter)

Comment 13

17 years ago
I close this as a dup of a new bug 80274. This one has a misleading description
(sorry). I think I now understand much better what is going on, specially that
this is not a mailnews bug, after all.

*** This bug has been marked as a duplicate of 80274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 14

17 years ago
Verified as such.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.