Closed Bug 800447 Opened 7 years ago Closed 6 years ago

The debugger client should provide events for connection failure (timeouts...), and for the case when the server disappears (connection lost)

Categories

(DevTools :: Debugger, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 898485

People

(Reporter: msucan, Assigned: ochameau)

References

(Blocks 1 open bug)

Details

(Whiteboard: [performance][profiler])

Currently it is not easy to track when the connection to the server is lost or if the connection timeouts, or something unexpected happens. We should have events for such cases - and we need to define those cases.
So to clarify a bit from our triage session, we would like to have more connectivity events and API to query where we are in the connection process. Useful for web console work.

Proposing 4 states to get this started: CONNECTING, CONNECTED, DISCONNECTED, ERROR.

filter on PUMPKINS!
Priority: -- → P3
Blocks: 809859
Totally. We should look at what sorts of errors the underlying XPCOM socket interfaces distinguish.
(this is needed by the toolbox connection screen)
Just a friendly ping. This is a bit of an annoyance when profiling on mobile.
we should probably bump priority on this if this is causing pain.
Priority: P3 → P2
Whiteboard: [performance][profiler]
If noone mind, I'd like to contribute to this bug, as we are already doing this in the simulator code and would prefer to upstream instead of having such event state management on top of DebuggerClient.
Assignee: nobody → poirot.alex
Blocks: 894352
No longer blocks: 894352
I think paul more or les implemented that via the connection-manager.
I think we can now close this bug. Feel free to reopen if you think there is still something missing.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 898485
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.