If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Request porting mach updates to Aurora

RESOLVED WORKSFORME

Status

()

Core
mach
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: WeirdAl, Unassigned)

Tracking

18 Branch
mozilla18
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox18-)

Details

(Reporter)

Description

5 years ago
It'd be really nice to get mach working on the Aurora branch.  I tried using mach there, and it failed.
(Reporter)

Updated

5 years ago
Target Milestone: mozilla17 → mozilla18
Version: 17 Branch → 18 Branch

Comment 1

5 years ago
mach is NPOTB and current m-c tip could be uplifted wholesale to mozilla-aurora without causing any trouble. However, I /think/ I need approval to land *anything* in mozilla-aurora.
tracking-firefox19: --- → ?
(In reply to comment #1)
> mach is NPOTB and current m-c tip could be uplifted wholesale to mozilla-aurora
> without causing any trouble. However, I /think/ I need approval to land
> *anything* in mozilla-aurora.

You may want to try to convince Alex to give you a blanket approval for mach stuff on branches.  ;-)

Comment 3

5 years ago
I think that's what I'm asking for... until mach is part of the build anyway. I'll try not to abuse it unless people request a specific fix/feature.

Comment 4

5 years ago
What's the risk of regression here? I read http://gregoryszorc.com/blog/2012/09/26/mach-has-landed/ and see that this mostly has to do with lowering the bar of contribution (which there's little of on Aurora/Beta). If there's any risk to taking mach, I'm inclined to not uplift.

(Aurora is 18 right now by the way)
tracking-firefox18: --- → ?
tracking-firefox19: ? → ---

Comment 5

5 years ago
There should be no risk since mach is not part of the build (yet). mach just gives developers an extra tool to use. And, since B2G is on Aurora, this could conceivably help with B2G development efforts.

Comment 6

5 years ago
OK - no need to track, but feel free to come up with a set of bugs you plan to uplift and we can give blanket approval given this is basically NPOTB.
tracking-firefox18: ? → -
Mach has ridden the trains to Aurora by now.  When there are specific mach changes that we want to uplift, we can request approval.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.