Closed Bug 800552 Opened 10 years ago Closed 10 years ago

[socorro-crashstats] topcrashers with signatures with non-ascii characters shouldn't break

Categories

(Socorro :: Webapp, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: peterbe, Unassigned)

References

()

Details

Attachments

(1 file)

This, for example, shouldn't cause problems: http://cl.ly/K5y1

Our urlencoding function isn't smart enough yet.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 782220
Status: RESOLVED → VERIFIED
Blocks: 775142
Scoobidiver, the python-based socorro-crashstats code and the production PHP code are surely too different to even port any patch.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #7)
> Scoobidiver, the python-based socorro-crashstats code and the production PHP
> code are surely too different to even port any patch.

If peterbe and rhelmer agree that's the case and there's no good workaround for production, how can we help Scoobidiver and mobile engineers grab a stack trace? Would it be possible for you to file a request for a custom report?
(In reply to Alex Keybl [:akeybl] from comment #8)
> (In reply to Robert Kaiser (:kairo@mozilla.com) from comment #7)
> > Scoobidiver, the python-based socorro-crashstats code and the production PHP
> > code are surely too different to even port any patch.
> 
> If peterbe and rhelmer agree that's the case and there's no good workaround
> for production, how can we help Scoobidiver and mobile engineers grab a
> stack trace? Would it be possible for you to file a request for a custom
> report?

This bug is for the new django version of crash-stats (which is undergoing sec review right now), I will file a new bug where we can discuss fixing this for the PHP app. If it's blocking work and possible to fix in the old site then we should do so, as we don't have a concrete ship date for the django version.
(In reply to Robert Helmer [:rhelmer] from comment #9)
> This bug is for the new django version of crash-stats (which is undergoing
> sec review right now), I will file a new bug where we can discuss fixing
> this for the PHP app.

bug 811948
(In reply to Alex Keybl [:akeybl] from comment #8)
> how can we help Scoobidiver and mobile engineers grab a stack trace? Would it be
> possible for you to file a request for a custom report?
I found bug 775142 that has a stack trace with the same signature except the non-ASCII character so it's the same issue. The problem is that we don't know if it's a common topcrasher (should be fixed in 18.0) or it's only hit by a single user several times (less important to fix).
No longer blocks: 775142
You need to log in before you can comment on or make changes to this bug.