The build system should error out when some directory is not used at all

RESOLVED DUPLICATE of bug 784841

Status

RESOLVED DUPLICATE of bug 784841
6 years ago
6 months ago

People

(Reporter: bjacob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Suppose that in a makefile I make a typo: I write

  TOOLS_DIRS += test

instead of

  TOOL_DIRS += test

Then I'm going to accidentally disable all my tests here.

It would be nice if the build system could say "hey, there are more subdirectories here than are mentioned in any known way in the Makefile. That must be a mistake!"

Original motivation: we accidentally disabled content/canvas mochitests by exactly this typo. See bug 798849 comment 26.
This won't be possible before bug 784841.
Depends on: 784841

Comment 2

6 years ago
We can't do this in make. pymake, maybe. Not make.

Well, we could do static analysis outside the context of the build system. That would be bug 774381 (which should likely be marked WONTFIX).

The long term solution is the work being done in bug 784841. In the new build system, there will be a whitelist of variables that can be assigned to. So, if you make this mistake/typo, the file fails to load.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 784841
Resolution: --- → WONTFIX

Comment 3

6 years ago
I read nothing in comments 1 and 2 which says that we're not interested in fixing this problem... ;-)
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 784841

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.