Crash when copying text and pasting into URL bar.

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
18 years ago
11 years ago

People

(Reporter: doctor__j, Assigned: alecf)

Tracking

({crash})

Trunk
Future
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: worksforme)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9+) Gecko/20010507
BuildID:    2001051004

Reproducible: Always
Steps to Reproduce:
1. Open "Help menu -> About Mozilla"
2. Select some text and copy it (either by pop-up menu or Edit menu)
3. Highlight whole line of text in URL bar, paste the text into it.

Actual Results:  Crash.

Expected Results:  Text got pasted into URL bar.

Windows error message:
MOZILLA caused an invalid page fault in
module MSVCRT.DLL at 017f:78001648.

Comment 1

18 years ago
WFM, build 2001050915, Win 95.

Comment 2

18 years ago
Windows 2000, Mozilla build 200105105: Trying to enter any text into the URL 
bar causes a crash.  I type 'w' and the crash occurs.  Data given:

ModName:js3250.dll
AppName:mozilla.exe
ModVer:4.0.0.0
Offset:0008ec4

Updated

18 years ago
Keywords: crash

Comment 3

18 years ago
Reporter do you have the talkback id from the crash?

Comment 4

18 years ago
Created attachment 35245 [details]
Talkback result

Comment 5

18 years ago
Still have the same problem on 20010517 build on Win 2000, but works on 
20010515 build. Updating URL field to reflect the problem.

In URL field type in any word, e.g. 'aaa' and hit enter (note: don't type in 
http://www.aaa.com, just type in aaa).

Attaching talkback results.

Comment 6

18 years ago
Confirm bug.  Is there something related to bug 80928.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

18 years ago
nav triage team:

Cladius, can you take a shot at reproducing this?
Reporter: we are unable to reproduce this crash at all. Can you give us a more 
consistent test case that happens in recent builds (20010523 or later) so that 
we can take a look at it. If you update the bug, please remove the nsbeta1- so 
that we'll reconsider it for an upcoming milestone. thanks! nav triage team. 
Keywords: nsbeta1-
Target Milestone: --- → Future

Comment 9

18 years ago
Still occurred on  20010522.
But little different than last report.

1. Launch Mozilla
2. Type yyy to URL bar then  hit Enter
3. You will get search result panel. Last time when I reported, before having this panel, already crashed.
4. Select any items in the side bar/search tab. May be you will have 4 candidates in there.
5. Click any of those.
6. Crash and a Proglam error dialog box displays. 
(Reporter)

Comment 10

18 years ago
I've tried to reproduce the bug using the "old way" as described in this bug
report, and I cannot get the crash.

However, I haven't tried Kasumi's way of getting a crash.

Comment 11

18 years ago
nav triage team:

Just tried this on my mac build using source pulled this morning (06/13/01). 
Can't reproduce the crash.

Claudius, can you try reproducing this, please?

Comment 12

18 years ago
nav triage team:

Adding worksforme to status whiteboard
Whiteboard: worksforme

Comment 13

18 years ago
VERIFIED WFM with 2001060704 build. (tried both scenarios)
It would be good if the reporter can poste a talkback ID#. (for a stack trace).

kasumi@netscape.com not the talkback result that you have posted. 
run mozilla/components/talkback.exe manually after talkback had send the crash.

(BTW: related to bug 85482 ?)

Comment 15

18 years ago
Tested on latest edition, this problem no longer occurred.
doctor__j@hotmail.com : Is that worksforme for you too ?
(Reporter)

Comment 17

18 years ago
Everything seems right, marking WFM.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.