Alarm is very quiet (possibly vibrate only), even when ringer is maxed out

VERIFIED FIXED

Status

Firefox OS
Gaia
P1
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Cww, Assigned: rexboy)

Tracking

({dogfood, unagi})

unspecified
x86
Gonk (Firefox OS)
dogfood, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I tried a few different alarm sounds and all it did was vibrate a couple times at the alarm time.  Ringer volume was maxed out.

STR: Set an alarm. Turn off screen Wait until time comes up.

Alarm sounds tried: 

AC_reedy_plastic_Retro_Alarm_clock
ALARM_progressive_dapple
AC_hear_me!_Retro_Alarm_Clock_RAW (this didn't even vibrate)
I got some error log with "unknow-content-type".

===== log =====
E/GeckoConsole( 5538): [JavaScript Warning: "HTTP "Content-Type" of "application/x-unknown-content-type" is not supported. Load of media resource app://clock.gaiamobile.org/style/ringtones/ALARM_progressive_dapple.mp3 failed." {file: "app://clock.gaiamobile.org/onring.html" line: 0}]

Gaia:  12a76c897aea24bdb3dee1cad0eb090bd3ffa2d2
Gecko: add440caf2f26a55f86e456502689709a9fed143

The previous issue should be reopened.
https://bugzilla.mozilla.org/show_bug.cgi?id=788204
Depends on: 788204
Bug 796259 also sounds like the same issue.
Should be automatically fixed by bug 788204
Assignee: nobody → iliu
this is a dup of Bug 796264, but according to this bug, it should be automatically fixed by bug 788204.
blocking-basecamp: --- → ?
This is the last thing preventing me tossing my galaxy nexus in the trash can.
Keywords: dogfood
Also to note : bug 804702.
Duplicate of this bug: 796264

Updated

5 years ago
Severity: normal → critical
blocking-basecamp: ? → +
Priority: -- → P1
Let's de-dependent the with bug 788204 first by converting the files we have right now to OGG and make sure it's playable. Rex, please do that, thanks.

Patryk will provided the new, correct OGG files in bug 799190.
Assignee: iliu → rexboy
Duplicate of this bug: 802271
Created attachment 675429 [details]
Fix silence alarm by changing all alarm sound to ogg format

I've converted all the alarms to OGG formats.
All links and default alarms set to MP3 files are modified to OGG files to workaround.
Attachment #675429 - Flags: review?(timdream+bugs)
Comment on attachment 675429 [details]
Fix silence alarm by changing all alarm sound to ogg format

r=me.
Attachment #675429 - Flags: review?(timdream+bugs) → review+
https://github.com/mozilla-b2g/gaia/pull/6011

Merged. Thank you!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Component: General → Gaia
Resolution: --- → FIXED

Comment 13

5 years ago
Defect is verified as fixed using build 20121231070201
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.