If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Dialer] Can't receive the phone call

RESOLVED DUPLICATE of bug 800898

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 800898
5 years ago
5 years ago

People

(Reporter: John Shih, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

205.63 KB, text/plain
Details
(Reporter)

Description

5 years ago
## Environment :
Otoro phone, build 2012-10-12
Build info: 
* "gaia" revision= 2ab7bd25e21b7931b700731389ad433286a18945
* "gecko" revision= c96b188e4b7d480bdd897eb7b368afc91b8e6e5f

## Repro :
1. Make a call from another phone to testing device

## Expected:
* Receive the call 

## Actual:
* Nothing happen

Comment 1

5 years ago
I will try to reproduce this issue in latest repo.
(Reporter)

Comment 2

5 years ago
Created attachment 670708 [details]
logcat
I found that in the latest gaia commit, "window.open" returns null, but it should return [object window].

Comment 4

5 years ago
Hi Hsin-Yi,

Are you mean the following code in dialer.js? 

   window.open(urlBase + '#' + screenState,
                'call_screen', 'attention');

Where are you see the return value?
(In reply to vliu from comment #4)
> Hi Hsin-Yi,
> 
> Are you mean the following code in dialer.js? 
> 
>    window.open(urlBase + '#' + screenState,
>                 'call_screen', 'attention');
> 
> Where are you see the return value?

Yes, this is the code I mentioned. 
Sorry that I didn't explain clear enough. I added additional debug messages to check the return value here.
Created attachment 670725 [details]
logcat-v2

According to logcat, the system message 'telephony-incoming' was sent successfully, so the platform worked fine.

I found that in the latest gaia, 'window.open' (in dialer.js) returns null, but it should return '[object window]'. This seems the root cause.
Attachment #670708 - Attachment is obsolete: true

Comment 7

5 years ago
Hi Hsin-Yi,

I added the dump function to observe the value of window object before and after window.open. They both showed [object Window].

    var dump_check = window;
    dump ("====> : dump_check = " + dump_check);
    window.open(urlBase + '#' + screenState,
                'call_screen', 'attention');
    dump ("====> : dump_check(1) = " + dump_check); 

Did I do it the same as you?
(In reply to vliu from comment #7)
> Hi Hsin-Yi,
> 
> I added the dump function to observe the value of window object before and
> after window.open. They both showed [object Window].
> 
>     var dump_check = window;
>     dump ("====> : dump_check = " + dump_check);
>     window.open(urlBase + '#' + screenState,
>                 'call_screen', 'attention');
>     dump ("====> : dump_check(1) = " + dump_check); 
> 
> Did I do it the same as you?

vliu, below is what I did:

var rt = window.open(urlBase + '#' + screenState, 'call_screen', 'attention');
dump(" window.open: " + rt);

Comment 9

5 years ago
Hi Hsin-Yi,

Sorry to confuse. I got the same result with you. Window object is created by gaia, it should be something wrong in it.

Comment 10

5 years ago
This bug is reported the same issue with bug 800898.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 800898
You need to log in before you can comment on or make changes to this bug.