segmentation fault in gtklayout.so

RESOLVED DUPLICATE of bug 78995

Status

--
critical
RESOLVED DUPLICATE of bug 78995
18 years ago
14 years ago

People

(Reporter: namonai, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
BuildID:    2001051008

Visit the Apple Store (http://www.apple.com) and play around for a while and the
browser will crash.  It is non-deterministic; sometimes it stays up for quite a
while but other times it crashes right away -- but it will always crash
regardless.

Here is the output of moz running under gdb:

  [snip]

Document http://www.apple.com/ loaded successfully
Document http://www.apple.com/store/ loaded successfully
Document http://store.apple.com/1-800-MY-APPLE/WebObjects/AppleStore loaded
successfully

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 30932)]
0x414959f5 in nsImageFrame::HandleEvent ()
   from /usr/local/mozilla/components/libgklayout.so
(gdb) bt
#0  0x414959f5 in nsImageFrame::HandleEvent ()
   from /usr/local/mozilla/components/libgklayout.so
#1  0x414b1419 in PresShell::HandleEventInternal ()
   from /usr/local/mozilla/components/libgklayout.so
#2  0x414b120c in PresShell::HandleEvent ()
   from /usr/local/mozilla/components/libgklayout.so
#3  0x415e481a in nsView::HandleEvent ()
   from /usr/local/mozilla/components/libgkview.so
#4  0x415e47be in nsView::HandleEvent ()
   from /usr/local/mozilla/components/libgkview.so
#5  0x415e47be in nsView::HandleEvent ()
   from /usr/local/mozilla/components/libgkview.so
#6  0x415edf0e in nsViewManager::DispatchEvent ()
   from /usr/local/mozilla/components/libgkview.so
#7  0x415e41ad in HandleEvent ()
   from /usr/local/mozilla/components/libgkview.so
#8  0x404f6ffa in nsWidget::DispatchEvent ()
   from /usr/local/mozilla/components/libwidget_gtk.so
#9  0x404f6f25 in nsWidget::DispatchWindowEvent ()
   from /usr/local/mozilla/components/libwidget_gtk.so
#10 0x404f7080 in nsWidget::DispatchMouseEvent ()
   from /usr/local/mozilla/components/libwidget_gtk.so
#11 0x404f741d in nsWidget::OnMotionNotifySignal ()
   from /usr/local/mozilla/components/libwidget_gtk.so
#12 0x404fb9bf in nsWindow::HandleGDKEvent ()
   from /usr/local/mozilla/components/libwidget_gtk.so
#13 0x404f1ce7 in dispatch_superwin_event ()
   from /usr/local/mozilla/components/libwidget_gtk.so
#14 0x404f1a3c in handle_gdk_event ()
   from /usr/local/mozilla/components/libwidget_gtk.so
#15 0x40670e4f in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0
#16 0x406a07f3 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#17 0x406a0dd9 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#18 0x406a0f8c in g_main_run () from /usr/lib/libglib-1.2.so.0
#19 0x405b8803 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#20 0x404e9ebc in nsAppShell::Run ()
   from /usr/local/mozilla/components/libwidget_gtk.so
#21 0x404cacea in nsAppShellService::Run ()
   from /usr/local/mozilla/components/libnsappshell.so
#22 0x0804d2e4 in main1 () at eval.c:41
#23 0x0804db75 in main () at eval.c:41
#24 0x401f0177 in __libc_start_main (main=0x804da48 <main>, argc=3, 
    ubp_av=0xbffffb9c, init=0x804a1dc <_init>, fini=0x804f528 <_fini>, 
    rtld_fini=0x4000e184 <_dl_fini>, stack_end=0xbffffb94)
    at ../sysdeps/generic/libc-start.c:129

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 78995 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.