CSS background:linear-gradient behaves differently to background:-moz-linear-gradient

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: daniel.p.richards, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.26 Safari/537.11

Steps to reproduce:

created a web-page with linear gradients specified using an angle. Non vendor prefixed gradient was specified, with fallback to vendor prefixed versions.


Actual results:

the gradient has been rotated by 90 degrees in Firefox 16.0.1 (demonstration - http://jsfiddle.net/5nanU/1/). It looks like the non-vendor-prefixed linear gradient has been implemented, but has different behaviour to the vendor-prefixed version.


Expected results:

the behaviour of the vendor-prefixed gradient and non-vendor-prefixed gradient should be identical.
(Reporter)

Comment 1

6 years ago
noted that this is expected - https://hacks.mozilla.org/2012/07/aurora-16-is-out/ - so I'll close this ticket. The strategy of still supporting a vendor prefix that is not standards compliant is very questionable.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.