OnKeyPressEvent and OnKeyReleaseEvent are fired twice each when a panel is focused.

RESOLVED DUPLICATE of bug 707623

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 707623
5 years ago
5 years ago

People

(Reporter: mconley, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

STR:

1) Start a debug version of Nightly with WidgetFocus logging (NSPR_LOG_MODULES=WidgetFocus:5 ./dist/bin/firefox)
2) Open a panel - either the Downloads Panel (by clicking on the Downloads button), or perhaps the Larry panel when clicking on the lock on a HTTPS page.
3) With the panel focused, press a single key, and watch the logging output. 

What happens?

Two consecutive OnKeyPressEvents are fired, followed by two OnKeyReleaseEvents.

What's expected?

Only one OnKeyPressEvent and one OnKeyReleaseEvent, per key press.
OS: Windows 7 → Linux
Duplicate of this bug: 774127
FWIW, on aa5e3b445810 (18 branch point), I'm seeing one OnKeyPressEvent, but two OnKeyReleaseEvents.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 707623
Hmm.  I am seeing the double OnKeyPressEvent with the Downloads Panel.
You need to log in before you can comment on or make changes to this bug.