implement tab modal prompts

RESOLVED DUPLICATE of bug 866304

Status

Firefox for Metro
Browser
P4
enhancement
RESOLVED DUPLICATE of bug 866304
5 years ago
4 years ago

People

(Reporter: ally, Unassigned)

Tracking

({pp, ux-interruption})

Trunk
All
Windows 8.1
pp, ux-interruption

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [metro-mvp-])

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Keywords: feature
Whiteboard: [metro-mvp]

Updated

5 years ago
OS: Mac OS X → Windows 8 Metro

Updated

5 years ago
Whiteboard: [metro-mvp] → [metro-mvp][LOE:2]
I think this is a nice-to-have, not a blocker for shipping.  (Note that even desktop Firefox still uses app-modal prompts for certain cases like HTTP Auth prompts.)
Priority: -- → P4
Whiteboard: [metro-mvp][LOE:2] → [metro-mvp?][LOE:2]

Updated

5 years ago
Whiteboard: [metro-mvp?][LOE:2] → [metro-mvp-][LOE:2]

Updated

5 years ago
Blocks: 842686
Keywords: feature
Whiteboard: [metro-mvp-][LOE:2]
Severity: normal → enhancement
Keywords: pp, ux-interruption
Hardware: x86 → All
Whiteboard: [metro-mvp-]

Updated

5 years ago
Component: General → Browser
Version: unspecified → Trunk
I accidentally created a dupe of this bug. The other bug has some patches and research in it, so I'm marking this one as the duplicate.

I think the rationale behind punting on this for v1 was based on the assumption that window-modal prompts were already working (or were easier to get working than tab-modal prompts). I think the amount of effort involved in properly implementing window-modal prompts is roughly equivalent to the amount of effort involved in switching to using desktop's implementation of tab-modal prompts, but the latter approach gives us code consolidation with desktop Firefox, so I think this is worth pursuing for v1.
Blocks: 831978
No longer blocks: 842686
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 866304

Updated

5 years ago
No longer blocks: 831978

Updated

5 years ago
Blocks: 831978
No longer blocks: 831978
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.