If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Ver 18 fails on 16.0.1

RESOLVED WORKSFORME

Status

Calendar
Lightning Only
--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: john ruskin, Unassigned)

Tracking

Lightning 1.6

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

Updated TBird from 15 to 16.0.1

Updated identified Lightning 1.7 as incompatible and requested permission to seek out 1.8, which I approved.

Reinstall of  TBird 16 and Light 1.8 went forward as expected.... however


Actual results:

On startup of TBird, the calendar fails to show more than nearly blank grid.

These ERRORS appear in sequence, without touching anything:

Failed to load native module at path 'C:\Users/..foo../AppData\Roaming\Thunderbird\Profiles\jy9gx3f5.default\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103}\components\calbasecomps.dll': (80520012) <unknown; can't get error from NSPR>

Timestamp: 10/13/2012 10:14:00 AM
Warning: Unknown property '-moz-border-radius'.  Declaration dropped.
Source File: chrome://testpilot/content/browser.css
Line: 227
Timestamp: 10/13/2012 10:14:00 AM
Warning: Use of Mutation Events is deprecated. Use MutationObserver instead.
Source File: chrome://calendar/content/widgets/calendar-widgets.xml
Line: 306

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:00 AM
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: chrome://calendar/content/calUtils.js
Line: 160

Timestamp: 10/13/2012 10:14:00 AM
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: chrome://calendar/content/calUtils.js
Line: 160

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/..foo../AppData/Roaming/Thunderbird/Profiles/jy9gx3f5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:01 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Interface module loaded.

Timestamp: 10/13/2012 10:14:01 AM
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/..foo../AppData/Roaming/Thunderbird/Profiles/jy9gx3f5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 160

Timestamp: 10/13/2012 10:14:01 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: resource:///modules/errUtils.js
Line: 91

Timestamp: 10/13/2012 10:14:02 AM
Error: Please do not load stuff in the multimessage browser directly, use the SummaryFrameManager instead.
Source File: resource:///modules/summaryFrameManager.js
Line: 85



Expected results:

None of that, for sure.....
(Reporter)

Updated

5 years ago
Severity: normal → critical

Comment 1

5 years ago
Are you using Norton virus protection? Norton is known to remove calbasecomps.dll with every new release and therefore Lightning can't work. Try to reinstall Lightning and check the Norton logs.
(Reporter)

Comment 2

5 years ago
Thanks for responding

After reporting the error, I manually downloaded the ver 1.8 and installed it, and the error disappeared. 

I am using AVG, and there was no hit on that DLL.

I thought, at first, that the bug was within the auto-update process with TBird; and still suspect that, since there was no [apparent] interruption in that update

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.