lightning 1.8 fails to operate

RESOLVED WORKSFORME

Status

Calendar
General
--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: john ruskin, Unassigned)

Tracking

Lightning 1.8
x86_64
Windows 7

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

Updated from 15 to 16.0.1, with a requested update for lightning from 1.7 to 1.8 due to compatibility.

Update fails as to lightning, and not sure whether it is an underlying problem in TBird 16.0.1, or Lightning.   Reporting this bug in both worlds.


Actual results:

On startup of TBird, the calendar fails to show more than nearly blank grid.

These ERRORS appear in sequence, without touching anything:



Failed to load native module at path 'C:\Users/..foo../AppData\Roaming\Thunderbird\Profiles\jy9gx3f5.default\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103}\components\calbasecomps.dll': (80520012) <unknown; can't get error from NSPR>

Timestamp: 10/13/2012 10:14:00 AM
Warning: Unknown property '-moz-border-radius'.  Declaration dropped.
Source File: chrome://testpilot/content/browser.css
Line: 227
Timestamp: 10/13/2012 10:14:00 AM
Warning: Use of Mutation Events is deprecated. Use MutationObserver instead.
Source File: chrome://calendar/content/widgets/calendar-widgets.xml
Line: 306

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:00 AM
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: chrome://calendar/content/calUtils.js
Line: 160

Timestamp: 10/13/2012 10:14:00 AM
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: chrome://calendar/content/calUtils.js
Line: 160

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:00 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/..foo../AppData/Roaming/Thunderbird/Profiles/jy9gx3f5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 42

Timestamp: 10/13/2012 10:14:01 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: chrome://calendar/content/calUtils.js
Line: 42

Interface module loaded.

Timestamp: 10/13/2012 10:14:01 AM
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/..foo../AppData/Roaming/Thunderbird/Profiles/jy9gx3f5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 160

Timestamp: 10/13/2012 10:14:01 AM
Error: TypeError: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: resource:///modules/errUtils.js
Line: 91

Timestamp: 10/13/2012 10:14:02 AM
Error: Please do not load stuff in the multimessage browser directly, use the SummaryFrameManager instead.
Source File: resource:///modules/summaryFrameManager.js
Line: 85



Expected results:

none of the above.

not sure if the underlying data is still there, since none of the underlying elements of the calendar work [for example, right click on the three calendars i have, turns up no response]

This could be a major problem for me personally, to say the least, if the data is gone, and could be for others similarly....

Not sure how to undo the install back to 1.5/1.7, without undoing the data set for the calendar
(Reporter)

Updated

6 years ago
Severity: normal → critical
(Reporter)

Comment 1

6 years ago
Ok......
I manually downloaded the add-on, and TBird/Lightning now works for me.

Maybe the error trail can identify why the automatic install failed ?
Component: General → General
Product: Thunderbird → Calendar
Version: 16 → Lightning 1.8
Are you using Norton virus protection?
(Reporter)

Comment 3

6 years ago
No, I am not.   And there was no apparent interruption in the download or the operating system during the relevant periods.
(Reporter)

Comment 4

6 years ago
Just wondering . . . might the auto download of the 1.8, via the final portion of the TBird update, been pulled from a source that had a defective DLL set in the server ?
Resolving as WFM per comment 1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.