Thunderbird hangs and allocates tons of memory (50mb/sec, up to 1GB)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: mka128, Unassigned)

Tracking

(Blocks: 1 bug, {memory-leak, perf})

15 Branch
x86
Windows 7
memory-leak, perf

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 671129 [details]
WinDbg stacktrace

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

I added my imap-mailbox to thunderbird, containing about 15000 messages in a hierarchical folder-structure. 


Actual results:

At some point during the download of the messages, thunderbird does not respond any more and keeps allocating more and more memory. After killing the thunderbird process and restarting thunderbird, it resumes downloading the messages and the problem occurs again after a few seconds. Switching to offline mode quickly enough after launch prevents the application from hanging.

Reinstallation of the programm / deleting and adding the mailbox again did not solve the problem.

Comment 1

6 years ago
please state how much memory
Severity: normal → critical
Keywords: mlk, perf
(Reporter)

Comment 2

6 years ago
it allocates with the speed of 50mb/second and stops at about 1GB, but the application keeps busy and does not respond to user input (seems like a busy loop)
Please use Tools > Activity Manager to try and see what's going on.
Flags: needinfo?(mka128)
(Reporter)

Comment 4

6 years ago
In the activity manager it says "Nachrichten werden indiziert" (Messages are being indexed) and in the subtitle "Zu indizierende Nachrichten werden ermittelt" (Messages to index are being determined)

Below there is another entry in the activity manager which says "19 Messages in inbox have been indexed"

The activity manager windows is busy, too, the progess bar is frozen.
Flags: needinfo?(mka128)

Comment 5

6 years ago
So when you are offline you can disable the global indexer temporarily in Options->advanced->General->enable global search and indexer. Then download the messages (while being online). You can then enable the indexer if you wish to use that feature. But anyway it should not make TB unresponsive when indexing.

Can you tell the specs of your machine CPU/RAM/disk? Or do you have your profile on a network share?
(Reporter)

Comment 6

6 years ago
I'm running thunderbird on a Core2 Duo 1,8ghz with 2Gigs of ram. My profile is stored on a local SATA drive. 

I disabled the indexer, downloaded all messages and activated it again. The problem reoccurred as soon as the indexing process started, independently of any download process. To me it looks as if there is a certain mail that causes the indexer to go into an endless loop. I left it running in that busy state for more than half an hour, it did not recover. Is there a way to log which messages have been indexed so that we can figure out which individual mail causes this problem?

Comment 7

6 years ago
Yes, you can install the GlodaQuilla extension https://addons.mozilla.org/thunderbird/addon/glodaquilla-search-indexing-en , which enables you to see which messages are already indexed (enable the 'gloda id' column in the message list) and also enable/disable indexing per folder.
Gloda also has a lot of built in debug/trace support - I'm in the middle of something right now, but if no-one else follows up with the info I'll get it as soon as I have time.
OK, I've figured out how to get detailed gloda logs...

First you need to set an advanced preference. Go to Preferences / Advanced / General and click on the "Config Editor..." button.

In the search box enter "mailnews.database.global.logging.dump". You should see one preference listed; if the Value is false double-click on the preference to toggle the value to true.

Then you need to run Thunderbird from the command line, because the debug output comes to the terminal window rather than the error console or a log file. If you have trouble doing that, your best bet is to ask on irc.mozilla.org/#thunderbird

The resulting log output will contain user IDs and account names for your mail account; you may want to edit out those details before you attach the output to this bug report.

Comment 10

6 years ago
(In reply to mka128 from comment #6)
> I'm running thunderbird on a Core2 Duo 1,8ghz with 2Gigs of ram. My profile
> is stored on a local SATA drive. 
> 
> I disabled the indexer, downloaded all messages and activated it again. The
> problem reoccurred as soon as the indexing process started, independently of
> any download process. 

you restarted TB after re-enabling, correct?   ref: Bug 550770
(Reporter)

Comment 11

6 years ago
Yes, I restarted it after changing the option. 

I installed GlodaQuilla and progressively added indexing to all mailbox folders, the problem did not occur anymore.

However, I will try to reproduce the problem and create gloda locks when I will have a little more time next week because I am also curious about the bug.

Updated

6 years ago
Summary: Thunderbird hangs and allocates tons of memory → Thunderbird hangs and allocates tons of memory (50mb/sec, up to 1GB)
(Reporter)

Comment 12

6 years ago
sorry guys, I can't reproduce that bug anymore, it seems to have been fixed with a new version

Comment 13

6 years ago
That can also be taken positively :) So you now have all indexing and the memory is OK?
Have you upgraded TB since the report?

Comment 14

6 years ago
wfm reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Blocks: 1330872
You need to log in before you can comment on or make changes to this bug.