Graphical glitch in certain site when zooming in of a page

RESOLVED FIXED in Firefox 18

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: alice0775, Assigned: mattwoodrow)

Tracking

({regression})

18 Branch
mozilla19
x86
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18+ verified, firefox19+ fixed)

Details

()

Attachments

(1 attachment)

Reporter

Description

7 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/90857937b601
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121013030542
http://hg.mozilla.org/releases/mozilla-aurora/rev/8ee98cea0f22
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121013042011

See forum http://forums.mozillazine.org/viewtopic.php?p=12372743#p12372743


Steps to reproduce:
 1. Start Firefox with HWA enabled
 2. Open http://arewefastyet.com/
 3. Zoom in(Ctrl++) (Ctrl++) (Ctrl++)... several times

Actual results:
 Graph labels do not clear, leaving multiple copies on the screen.

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/b274e8e3479f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928160219
Bad:
http://hg.mozilla.org/mozilla-central/rev/b62b229a4d41
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928161018
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b274e8e3479f&tochange=b62b229a4d41


Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9f476b4ac1e1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928040137
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6b58397ad735
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928042236
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735

Suspected: Bug 539356
Reporter

Updated

7 years ago
Blocks: dlbi
Keywords: regression
Matt assigning this bug to you as it is a suspected regression from Bug 539356 . Please feel free to reassign if needed or let us know if you need qa help to confirm the bug .
Assignee: nobody → matt.woodrow
https://hg.mozilla.org/mozilla-central/rev/909bfa275c7c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
(In reply to Matt Woodrow (:mattwoodrow) from comment #3)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/909bfa275c7c

Matt are we waiting for some more testing here or is there risk involved here for this patch not to be uplifted to Aurora ?
Assignee

Comment 6

7 years ago
Comment on attachment 671641 [details] [diff] [review]
Invalidate ThebesLayer if the app units per dev pixel changes

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 539356
User impact if declined: Incorrect painting when zooming
Testing completed (on m-c, etc.): Been on m-c for over a week.
Risk to taking this patch (and alternatives if risky): Very low risk, just causes more painting in some cases.
String or UUID changes made by this patch: None
Attachment #671641 - Flags: approval-mozilla-aurora?
Comment on attachment 671641 [details] [diff] [review]
Invalidate ThebesLayer if the app units per dev pixel changes

Approving for Aurora based on the bake time and also coz this is a DLBI regression
Attachment #671641 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Firefox 18 beta 3 - there are no graphical glitch when zooming in of a page and HWA is enabled (used the STR from the Description).

Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121205060959
QA Contact: simona.marcu
You need to log in before you can comment on or make changes to this bug.