Thunderbird build is broken after Bug 779473 fixed

RESOLVED DUPLICATE of bug 801383

Status

RESOLVED DUPLICATE of bug 801383
6 years ago
6 years ago

People

(Reporter: ojab, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
make[7]: Entering directory `/home/ojab/opt/mail/db/mork/src'
c++ -o morkEnv.o -c -I../../../mozilla/dist/stl_wrappers -I../../../mozilla/dist/system_wrappers -include /sources/comm-central/mozilla/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DMOZ_THUNDERBIRD=1 -DOSTYPE=\"Linux3.6\" -DOSARCH=Linux  -I/sources/comm-central/db/mork/src -I. -I../../../mozilla/dist/include -I../../../mozilla/dist/include/nsprpub  `/home/ojab/opt/mail/mozilla/dist/sdk/bin/nspr-config --prefix=/home/ojab/opt/mail/mozilla/dist --includedir=/home/ojab/opt/mail/mozilla/dist/include/nspr --cflags` -I/home/ojab/opt/mail/mozilla/dist/include/nss      -fPIC  -pedantic -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Werror=conversion-null -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -Wno-long-long -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe  -DNDEBUG -DTRIMMED -g -Os -freorder-blocks  -fomit-frame-pointer   -DMOZILLA_CLIENT -include ../../../comm-config.h -MD -MF .deps/morkEnv.pp /sources/comm-central/db/mork/src/morkEnv.cpp
In file included from /sources/comm-central/db/mork/src/morkEnv.cpp:15:0:
/sources/comm-central/db/mork/src/morkNode.h:223:24: warning: ‘virtual mork_refs morkNode::AddStrongRef(morkEnv*)’ was hidden [-Woverloaded-virtual]
In file included from /sources/comm-central/db/mork/src/morkEnv.h:14:0,
                 from /sources/comm-central/db/mork/src/morkEnv.cpp:23:
/sources/comm-central/db/mork/src/morkObject.h:93:14: warning:   by ‘virtual nsresult morkObject::AddStrongRef(nsIMdbEnv*)’ [-Woverloaded-virtual]
In file included from /sources/comm-central/db/mork/src/morkEnv.cpp:15:0:
/sources/comm-central/db/mork/src/morkNode.h:224:24: warning: ‘virtual mork_refs morkNode::CutStrongRef(morkEnv*)’ was hidden [-Woverloaded-virtual]
In file included from /sources/comm-central/db/mork/src/morkEnv.h:14:0,
                 from /sources/comm-central/db/mork/src/morkEnv.cpp:23:
/sources/comm-central/db/mork/src/morkObject.h:96:14: warning:   by ‘virtual nsresult morkObject::CutStrongRef(nsIMdbEnv*)’ [-Woverloaded-virtual]
/sources/comm-central/db/mork/src/morkEnv.cpp: In destructor ‘virtual morkEnv::~morkEnv()’:
/sources/comm-central/db/mork/src/morkEnv.cpp:67:14: warning: deleting object of abstract class type ‘nsIMdbHeap’ which has non-virtual destructor will cause undefined behaviour [-Wdelete-non-virtual-dtor]
/sources/comm-central/db/mork/src/morkEnv.cpp: In member function ‘void morkEnv::NewErrorAndCode(const char*, mork_u2)’:
/sources/comm-central/db/mork/src/morkEnv.cpp:363:49: error: operands to ?: have different types ‘mork_u2 {aka short unsigned int}’ and ‘tag_nsresult’
/sources/comm-central/db/mork/src/morkEnv.cpp: In member function ‘void morkEnv::NewError(const char*)’:
/sources/comm-central/db/mork/src/morkEnv.cpp:375:20: error: cannot convert ‘tag_nsresult’ to ‘mork_u4 {aka unsigned int}’ in assignment
/sources/comm-central/db/mork/src/morkEnv.cpp: In member function ‘virtual nsresult morkEnv::GetHeap(nsIMdbHeap**)’:
/sources/comm-central/db/mork/src/morkEnv.cpp:592:48: error: no match for ‘operator==’ in ‘heap->nsIMdbHeap::HeapAddStrongRef((&((morkEnv*)this)->morkEnv::<anonymous>)) == 0’
make[7]: *** [morkEnv.o] Error 1
make[7]: Leaving directory `/home/ojab/opt/mail/db/mork/src'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `/home/ojab/opt/mail/db/mork'
(Reporter)

Comment 1

6 years ago
/me slow
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801383
You need to log in before you can comment on or make changes to this bug.