Closed Bug 801457 Opened 7 years ago Closed 7 years ago

XULRunner windows builds busted since Sep 22 in winEmbed, cannot convert from 'uint32_t' to 'nsresult'

Categories

(Toolkit Graveyard :: XULRunner, defect)

x86
Windows Server 2003
defect
Not set

Tracking

(firefox18+ fixed)

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 + fixed

People

(Reporter: nthomas, Assigned: m_kato)

References

Details

Attachments

(1 file)

Logs are in https://ftp.mozilla.org/pub/mozilla.org/xulrunner/tinderbox-builds/mozilla-central-win32/

eg:
e:/builds/moz2_slave/m-cen-w32-xr/build/obj-firefox/_virtualenv/Scripts/python.exe -O /e/builds/moz2_slave/m-cen-w32-xr/build/build/cl.py cl -FowinEmbed.obj -c   -DXPCOM_GLUE -DXPI_NAME=winembed -I/e/builds/moz2_slave/m-cen-w32-xr/build/embedding/tests/winEmbed -I/e/builds/moz2_slave/m-cen-w32-xr/build/embedding/tests/winEmbed -I. -I../../../dist/include  -Ie:/builds/moz2_slave/m-cen-w32-xr/build/obj-firefox/dist/include/nspr -Ie:/builds/moz2_slave/m-cen-w32-xr/build/obj-firefox/dist/include/nss        -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4345 -wd4351 -wd4800 -we4553 -GR-  -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oy -MD            -FI ../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT  /e/builds/moz2_slave/m-cen-w32-xr/build/embedding/tests/winEmbed/winEmbed.cpp
winEmbed.cpp^M
e:/builds/moz2_slave/m-cen-w32-xr/build/embedding/tests/winEmbed/winEmbed.cpp(238) : error C2440: '=' : cannot convert from 'uint32_t' to 'nsresult'^M
        Conversion to enumeration type requires an explicit cast (static_cast, C-style cast or function-style cast)^M

Seems likely this is due to bug 777292 landing on Sep 21st. Any fix needs to land on mozilla-central and aurora.
Last successful build on m-c was
  xulrunner-18.0a1.en-US.win32.zip	21-Sep-2012 04:46 	19M
on rev 48c4938eaf57. Aurora broke when the 18.0 code was merged there.
Attached patch fixSplinter Review
Attachment #671306 - Flags: review?(benjamin)
Attachment #671306 - Flags: review?(benjamin) → review+
Thanks for the fix, Makoto!
https://hg.mozilla.org/integration/mozilla-inbound/rev/6f970ea66426
Assignee: nobody → m_kato
Target Milestone: --- → mozilla19
https://hg.mozilla.org/mozilla-central/rev/6f970ea66426
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 671306 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 777292
User impact if declined: cannot build xulrunner with --enable-tests (default build option)
Testing completed (on m-c, etc.): this is build issue
Risk to taking this patch (and alternatives if risky): too low risk.  This fix is test tool
String or UUID changes made by this patch: no
Attachment #671306 - Flags: approval-mozilla-aurora?
Attachment #671306 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.