If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmark gets deleted if droped onto the column picker

VERIFIED FIXED in mozilla0.9.6

Status

SeaMonkey
Bookmarks & History
P2
major
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Chris Lyon, Assigned: Paul Chen)

Tracking

({dataloss})

Trunk
mozilla0.9.6
x86
Windows 2000
dataloss

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using build 2001051004 on Win2K

Steps to Reproduce:
1. Open Manage Bookmarks window
2. Drag and drop a bookmark onto the column picker

Result:
The bookmark gets deleted

It also generates this error:
Error: uncaught exception: [Exception... "Component returned failure code: 
0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIRDFContainer.InsertElementAt]"  
nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: 
chrome://communicator/content/bookmarks/bookmarksDD.js :: anonymous :: line 
319"  data: no]
Source File: chrome://global/content/nsDragAndDrop.js
Line: 105

It also generates the error seen in bug 80149.

This was originally part of bug 25741.

Comment 1

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
Adding dataloss keyword.
Keywords: dataloss
(Assignee)

Comment 3

16 years ago
nav triage team:

Marking nsbeta1+, p2, and mozilla1.0
Keywords: nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0
dataloss -> moving up to mozilla0.9.5
Target Milestone: mozilla1.0 → mozilla0.9.5

Comment 5

16 years ago
0.9.5 is out the door. bumping TM up by one.
Target Milestone: mozilla0.9.5 → mozilla0.9.6
Created attachment 53553 [details] [diff] [review]
patch to fix
patch checks to make sure we're not dragging/dropping on head row. 
Status: NEW → ASSIGNED
Keywords: patch, review
(Assignee)

Comment 8

16 years ago
Comment on attachment 53553 [details] [diff] [review]
patch to fix

r=pchen
Attachment #53553 - Flags: review+
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
Fix checked in. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.