GMail configuration file makes TB unhappy

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR:
1) download TB 17 (current beta)
2) create a new profile
3) add your existing gmail account

ER:
Yay autoconf

AR:
Not-so-yay autoconf:

    -- Exception object --
    +  (string) The config file XML does not contain an email account configuration.
    *
     
    -- Exception object --
    + _message (string) ''
    + stack (string) 313 chars
    + code (number) 0
    + uri (string) 'http://autoconfig.gmail.com/mail/config-v1.1.xml'
    + message (string) ''
    + toString (function) 4 lines
    *
    -- Stack Trace --
    Exception@chrome://messenger/content/accountcreation/util.js:156
    ServerException@chrome://messenger/content/accountcreation/fetchhttp.js:268
    FetchHTTP._response@chrome://messenger/content/accountcreation/fetchhttp.js:190
    FetchHTTP.start/request.onerror@chrome://messenger/content/accountcreation/fetchhttp.js:114 

thus says my console. My DNS (and, afaict, several others) doesn't believe autoconfig.gmail.com actually exists.
I should have noted: it seems account setup then continues pretty normally (as far as I can tell?). But I'm not sure if there was supposed to be interesting information in that config file that would have made a difference. In any case, ideally there should be no errors and no mention of this old config file should be around.

Comment 2

6 years ago
> My DNS (and, afaict, several others) doesn't believe autoconfig.gmail.com actually exists.

Ditto here.

This is normal. We check the ISP whether they have a config on their server. They don't, and we continue normally with other alternatives.

I don't think we put that exception on the console, do you have any additional developer extensions installed?

INVALID: Not a bug. No actual problem.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(In reply to Ben Bucksch (:BenB) from comment #2)
> > My DNS (and, afaict, several others) doesn't believe autoconfig.gmail.com actually exists.
> 
> Ditto here.
> 
> This is normal. We check the ISP whether they have a config on their server.
> They don't, and we continue normally with other alternatives.
> 
> I don't think we put that exception on the console, do you have any
> additional developer extensions installed?
> 
> INVALID: Not a bug. No actual problem.

As I wrote in the steps to reproduce, this was a new profile. So no, there's no extensions. It would be nice if this didn't spam stderr though, and I didn't make up that copy-paste. :-)

Comment 4

6 years ago
Ah, you mean the terminal console. I thought the JS error console.
(Assignee)

Updated

6 years ago
Component: ispdb → ISPDB Server
Product: Mozilla Messaging → Webtools
You need to log in before you can comment on or make changes to this bug.