HTML code is displayed in code snippets

RESOLVED DUPLICATE of bug 780688

Status

Mozilla Developer Network
General
RESOLVED DUPLICATE of bug 780688
5 years ago
5 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20120911232325

Steps to reproduce:

* go to https://developer.mozilla.org/en-US/docs/DOM/Touch_events


Actual results:

* see in the last snippet that HTML code is displayed and not rendered

If you try to edit the article, you'll see that there are links as well as other tags in this snippets, but this renders correctly in edit mode.


Expected results:

* either the HTML should be stripped or parsed
* something should be done in edit mode to warn the editor that his HTML or style won't work. I've no good idea to achieve this.
Do you know how this is supposed to display sheppy?
I think this is a dupe of bug 780688. But we need a way to have links in code snippets.
  
> * something should be done in edit mode to warn the editor that his HTML or
> style won't work. I've no good idea to achieve this.

At least we should add that to our meta documentation / how to contribute pages.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780688
You need to log in before you can comment on or make changes to this bug.