please start syncing all of the releng repos to github

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: bhearsum, Assigned: rail)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
build/buildapi
build/mozharness
build/opsi-package-sources
build/preproduction
build/puppet-manifests
build/rpm-sources
build/talos
build/partner-repacks
build/puppet
build/tools

build/tools is already being synced to mozilla/build-tools on github, so please coordinate with me so I can turn off my job and delete the old repo.
(Assignee)

Comment 1

6 years ago
Some of the listed repos are already exist on github. There are some scenarios for them below:

1) Remove them, and replace with freshly created ones

2) Create new ones, leave the older one side by side (for a reasonable period of time). 
   In case of name conflict:
   2.1) Rename the old one
   2.2) Use a stupid name (build-mozharness-supernewone) for new ones

3) Reuse hg-git map file to continue using the same repo. I would like to avoid this because we sync default branch only in old repos and hit some issues with some repos in the past.

I would prefer to proceed with scenario 1).
(Reporter)

Comment 2

6 years ago
(In reply to Rail Aliiev [:rail] from comment #1)
> Some of the listed repos are already exist on github. There are some
> scenarios for them below:
> 
> 1) Remove them, and replace with freshly created ones
> 
> 2) Create new ones, leave the older one side by side (for a reasonable
> period of time). 
>    In case of name conflict:
>    2.1) Rename the old one
>    2.2) Use a stupid name (build-mozharness-supernewone) for new ones
> 
> 3) Reuse hg-git map file to continue using the same repo. I would like to
> avoid this because we sync default branch only in old repos and hit some
> issues with some repos in the past.
> 
> I would prefer to proceed with scenario 1).

a+ from me. I don't think it's worthwhile bothering with 3) because of how few consumers we have. 2) might be ok, but we'll want to delete the old repos later. 1) is probably as long as we give a few days notice to release@
(Assignee)

Comment 3

6 years ago
Created attachment 673245 [details] [diff] [review]
configs

* doesn't contain build/tools (to be done separately)
* the config will be landed once the repos a created on github and synced initially (see the next patch)
Attachment #673245 - Flags: review?(hwine)
(Assignee)

Comment 4

6 years ago
Created attachment 673246 [details]
runme

A script to be run on the git conversion host.
Attachment #673246 - Flags: review?(hwine)
Comment on attachment 673245 [details] [diff] [review]
configs

lgtm - awesome that I knew nothing about this until the review came :)
Attachment #673245 - Flags: review?(hwine) → review+
Comment on attachment 673246 [details]
runme

lgtm - 2 thoughts on improvements (as this could take an indeterminate amount of time):

 1. avoid blocking on one bad repo by appending "|| true" to the timeit line. You'll need to review all the logs anyway
 2. add at the very bottom: mail -s DONE rail@mozilla.com </dev/null
Attachment #673246 - Flags: review?(hwine) → review+
(Assignee)

Comment 7

6 years ago
Created attachment 673279 [details]
runme

* address comments
* carry over r=hwine
Attachment #673246 - Attachment is obsolete: true
Attachment #673279 - Flags: review+
Comment on attachment 673245 [details] [diff] [review]
configs

Late catch - we also need to update the file 'status' to include information on job_04.cmds. Should have been done when we created it - docs being updated.
(Assignee)

Comment 10

6 years ago
Created attachment 673293 [details] [diff] [review]
add tools

r=hwine on IRC
Attachment #673293 - Flags: review+
(Assignee)

Comment 12

6 years ago
~/etc upated
(Assignee)

Comment 13

6 years ago
The current repositories:

hg repo -> github repo (renamed old github repo)
build/buildapi -> build-buildapi (buildapi-old)
build/mozharness -> build-mozharness (mozharness-old)
build/opsi-package-sources -> build-opsi-package-sources (opsi-package-sources-old)
build/preproduction -> build-preproduction (no -old)
build/puppet-manifests -> build-puppet-manifests (puppet-manifests-old)
build/rpm-sources -> build-rpm-sources (no -old)
build/talos -> build-talos (talos-old)
build/partner-repacks -> build-partner-repacks (partner-repacks-old)
build/puppet -> build-puppet (puppet-old)
build/tools -> build-tools (build-tools-old)

I'm going to delete the old ones sometimes this week.
(Assignee)

Updated

6 years ago
Priority: -- → P2
(Assignee)

Comment 14

6 years ago
All done here
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.