Unable to launch the Marketplace in the AboutHomePromoBox

VERIFIED FIXED in Firefox 19

Status

()

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: bnicholson)

Tracking

({regression, reproducible})

Trunk
Firefox 19
ARM
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox19 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR: Tap the Apps Marketplace promo box - nothing happens

D/AboutHomePromoBox( 4260): Sending message to Gecko: 3155741 - Tab:Add

Private Browsing regression?

--
Nightly (10/15)
Samsung Galaxy Nexus (Android 4.1.1)
(Reporter)

Comment 1

6 years ago
Regression from bug 797075 with some refactoring; AboutHomePromoBox uses Tab:Add
Blocks: 797075
Keywords: regressionwindow-wanted
(Assignee)

Comment 2

6 years ago
Oops...looks like I missed some Tab:Add messages.
Assignee: nobody → bnicholson
(Assignee)

Comment 3

6 years ago
Created attachment 671512 [details] [diff] [review]
Use loadUrl() to open the marketplace tab
Attachment #671512 - Flags: review?(mark.finkle)
Comment on attachment 671512 [details] [diff] [review]
Use loadUrl() to open the marketplace tab

Add a simple test?
Attachment #671512 - Flags: review?(mark.finkle) → review+
(In reply to Mark Finkle (:mfinkle) from comment #4)
> Comment on attachment 671512 [details] [diff] [review]
> Use loadUrl() to open the marketplace tab
> 
> Add a simple test?

Hmm, adding a test that does not open a live website (http://marketplace.mozilla.org) might not be so easy.

Comment 7

6 years ago
https://hg.mozilla.org/mozilla-central/rev/f8e52edff71e
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
status-firefox19: affected → verified
You need to log in before you can comment on or make changes to this bug.