Newly added review doesn't show up

VERIFIED FIXED in 2012-10-18

Status

Marketplace
Consumer Pages
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: krupa, Assigned: Andy McKay)

Tracking

({regression})

2012-10-18
regression
Points:
---

Details

(URL)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/app/littlealchemy/reviews/add
2. Add a review (rating and comment) and Save.
3. Click Edit review
4. Navigate back to details page for the app.
5. Notice the review section.


observed behavior:
After step #3, The edit page doesn't retain the user's rating and review comment.
After step #5, the details page does not show the newly added review.


screencast: http://screencast.com/t/keE2THbzOdE
Is this just caching or is something failing?  Andy, can you investigate?
Assignee: nobody → amckay
Target Milestone: --- → 2012-10-18

Comment 2

6 years ago
This is a fragments cache thing. Potch had an idea about how to fix this.

Comment 3

6 years ago
Sooooo...Potch didn't get to this before he left. Here's the gist of the bug (krupa tried to pull a two-fer on this one, but potch already said he'd WONTFIX the details page part if she files it separately):

- When the user visits the add review page, fragment loader caches the page.
- When the user clicks Edit Review (which is at the same URL as the add review page), they get the cached fragment
- The user sees a blank form instead of their existing review because the fragment is from before the user wrote the review.

:(

Potch's idea was to add a flag in the page context that tells fragments.js not to cache the page. I don't know how far on this he got or whether he even started.

Andy: did you still want this or do you want me to take a stab at it?
(Assignee)

Comment 4

6 years ago
I've got zero idea how or what this fragment stuff is, so it would take me a while to get there.

Comment 5

6 years ago
Earlier today...

potch> basta: gotta shut down for the rest of this flight, will land fragment cache disabling with an r? a bit later

Sounds like you're off the hook.
this works now with potch's fix
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 7

5 years ago
Verified as fixed : http://screencast.com/t/dAT7Z0bHig
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.