Closed Bug 801763 Opened 7 years ago Closed 7 years ago

crash in nsRootPresContext::ApplyPluginGeometryUpdates

Categories

(Core :: Layout, defect, critical)

18 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla19
Tracking Status
firefox18 + verified
firefox19 --- verified

People

(Reporter: scoobidiver, Assigned: roc)

References

Details

(Keywords: crash, regression, topcrash)

Crash Data

Attachments

(1 file)

It first appeared in 19.0a1/20121015. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=57304bbf9c0e&tochange=942ed5747b63
It's likely a regression from bug 626245.

Signature 	nsRootPresContext::ApplyPluginGeometryUpdates() More Reports Search
UUID	869101ff-5b56-453a-8454-fa4a42121015
Date Processed	2012-10-15 17:23:28
Uptime	30
Install Age	30 seconds since version was first installed.
Install Time	2012-10-15 17:22:43
Product	Firefox
Version	19.0a1
Build ID	20121015030612
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 15 stepping 13
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x2a02, AdapterSubsysID: 30d8103c, AdapterDriverVersion: 8.15.10.1930
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers+ 
EMCheckCompatibility	True
Adapter Vendor ID	0x8086
Adapter Device ID	0x2a02
Total Virtual Memory	4294836224
Available Virtual Memory	3823800320
System Memory Use Percentage	46
Available Page File	6576746496
Available Physical Memory	2312400896

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsRootPresContext::ApplyPluginGeometryUpdates 	layout/base/nsPresContext.cpp:2664
1 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:472
2 	winmm.dll 	timeGetTime 	
3 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:555
4 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:612
5 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:82
6 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:208
7 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:182
8 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
9 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:232
10 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:290
11 	xul.dll 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3792
12 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3858
13 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3933

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsRootPresContext%3A%3AApplyPluginGeometryUpdates%28%29
Attached patch fixSplinter Review
I'm not sure how we would get a registered plugin with a toplevel widget, but this should work around it.
Assignee: nobody → roc
Attachment #671655 - Flags: review?(matspal)
Comment on attachment 671655 [details] [diff] [review]
fix

r=mats, I'd prefer a MOZ_ASSERT though to make sure it's not missed/ignored.
Attachment #671655 - Flags: review?(matspal) → review+
We'll want to take this patch on Aurora, if the patch helps at all.
https://hg.mozilla.org/mozilla-central/rev/3d48c911df8d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
After the uplift of bug 626245's patch, it's #3 top crasher in 18.0a2 over the last day.
Keywords: topcrash
Version: 19 Branch → 18 Branch
Tracking for FF18 as it is a top crasher . Please uplift for aurora after needed bake time/testing on central .
Can someone tell me why the second link shows no crashes after the 18th, but the graph in comment #9 does?
The graph in comment 9 shows all 19.0a1 crashes.  The graph in comment 8
has the right signature, but for all versions - if you sort on the Build
column (click on the column head) you'll see that the ones newer than
20121018030618 are all 18.0a2, which is consistent with the last graph
in comment 10, which has the right signature and version.  As far as I
can tell there's no crash report for trunk after the fix landed.
(In reply to Mats Palmgren [:mats] from comment #12)
> As far as I can tell there's no crash report for trunk after the fix landed.
Confirmed.
Status: RESOLVED → VERIFIED
Comment on attachment 671655 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 626245
User impact if declined: crashes involving plugins, probably mysterious
Testing completed (on m-c, etc.): fix verified on central
Risk to taking this patch (and alternatives if risky): very low-risk patch, no known alternative
String or UUID changes made by this patch: none
Attachment #671655 - Flags: approval-mozilla-aurora?
Comment on attachment 671655 [details] [diff] [review]
fix

Approving on aurora as its a low risk patch caused by Bug 626245 landed on FF18
Attachment #671655 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This is the crash referred in comment 17: https://crash-stats.mozilla.com/report/index/719c18c3-2145-44a4-894a-2c85c2121104.

Robert, please let me know if this crash does have to do with this bug.
The stack trace in comment 18 does not make sense, please disregard it.
You need to log in before you can comment on or make changes to this bug.