Browser's bottom toolbar is not hidden when virtual keyboard is open

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Browser
P4
normal
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:Keyboard & IME], b2g-desktop-builds)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 671575 [details]
Browser_toolbar_screenshot.png

Please see the attached screenshot. This browser bug is similar to Messages bug 796337.
(Reporter)

Updated

6 years ago
OS: Android → All
Whiteboard: [label:Keyboard & IME]
I can't reproduce this exactly, I see a grey bar but it isn't the toolbar.

A similar bug was already fixed but what I see now seems to be a problem with the scrolling animation because if you scroll the page up and down it disappears. This seems to be a repainting issue and therefore possibly a duplicate of bug 798194

This also *may* get fixed by https://github.com/mozilla-b2g/gaia/pull/5873

cpeterson would you mind re-testing and confirming whether you still see the buttons on the toolbar?
(Reporter)

Comment 2

6 years ago
(In reply to Ben Francis [:benfrancis] from comment #1)
> cpeterson would you mind re-testing and confirming whether you still see the
> buttons on the toolbar?

I can still reproduce this bug. I don't think it is a painting bug because the Back and Bookmark buttons still work as expected. Scrolling the page does not close the toolbar.
Hmm, weird. I still get different results to you in today's build.

Can you provide some steps to reproduce, including the URL you're loading and which text box (if any) you're selecting?

Thanks
(Reporter)

Comment 4

6 years ago
I still see the problem on my B2G Desktop Build, but not on my B2G phone. Investigating...
(Reporter)

Comment 5

6 years ago
This bug is real, but a low priority because it only affects B2G Desktop.
Priority: -- → P4
Whiteboard: [label:Keyboard & IME] → [label:Keyboard & IME], b2g-desktop-builds
Works for me in latest build (assuming you delete responsive.css in shared to make Gaia usable but that's a separate issue for B2G Desktop).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.