Flash in content iframe inside a xul:panel fails

RESOLVED FIXED in mozilla20

Status

()

Core
Plug-ins
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mixedpuppy, Assigned: roc)

Tracking

unspecified
mozilla20
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I'm not certain where this should go or who to cc, so here it goes anyway.

Flash in a content iframe in a xul:panel fails to work properly.  This is most apparent if it is a Flash video.  You'll hear the sound, and if you click in the panel in a non-flash area, then back in the flash area, the video frame will update once.

HTML video works fine in this situation.
Is this Mac-only?
Component: SocialAPI → Plug-ins
Product: Firefox → Core
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #1)
> Is this Mac-only?

Nope, I can see this on Windows 7.
bug 771351 suggests that plugins in panels should just be disabled entirely, though it looks like that comment was later updated to refer only to windowed plugins.
Are we talking about windowless Flash (wmode=opaque/transparent) or windowed Flash?

Windowed Flash is disabled in popups (including XUL panels); the objects won't be visible. We don't want to change that, and it would be difficult.

Windowless Flash should work just fine. If it doesn't, gimme a testcase and we'll fix it.
Oh, this was filed on Mac, where the distinction is blurred :-(. We probably need to do some work to get any kind of windowless plugin working in popups on Mac.

They should already work on Windows though.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #4)
> Are we talking about windowless Flash (wmode=opaque/transparent) or windowed
> Flash?

The content is trying to play a flash video in the panel, so I guess that means windowed.
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 7

6 years ago
wmode is opaque, here is an embed tag that is a failure case:

<embed type="application/x-shockwave-flash" src="https://www.youtube.com/v/b4AoSBqY_GI?version=3&amp;autohide=1&amp;autoplay=1&amp;rel=0&amp;showinfo=0&amp;showsearch=0" style="display: block;" id="swf_ua20wjd11" name="swf_ua20wjd11" bgcolor="#FFFFFF" quality="high" scale="scale" allowfullscreen="true" allowscriptaccess="never" salign="tl" wmode="opaque" flashvars="width=413&amp;height=232" height="232" width="413">
OK, that should work, on Windows and Linux at least and we can make it work on Mac too.

Do you have a simple testcase for this? If not I can try to make one.
(Reporter)

Updated

6 years ago
Duplicate of this bug: 723211
(Reporter)

Updated

6 years ago
Duplicate of this bug: 805836
(Reporter)

Comment 11

6 years ago
We need to revisit this issue.  roc, comment #7 is the best test case I have to reproduce the problems.  I'm not sure how to help move this forward, but am willing to with some guidance.
(Reporter)

Comment 12

6 years ago
note there are two issues here, one that flash video doesn't play correctly, the second, bug 813393, video keeps playing if the panel is closed.
Created attachment 685590 [details] [diff] [review]
(partial?) fix

This fixes it for me on Windows.

This fix won't affect Mac. On Mac we have the problem that we don't allow windowed plugins to be instantiated in popups at all, and all Mac plugins are treated as windowed for that. So Mac needs a completely different fix.
Assignee: nobody → roc
Attachment #685590 - Flags: review?(tnikkel)

Comment 14

6 years ago
Why are mac plugins treated as windowed? I thought all mac plugins were windowless by design.

Comment 15

6 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #14)
> Why are mac plugins treated as windowed? I thought all mac plugins were
> windowless by design.

Mac plugins are windowless from the POV of NPAPI. We implement them as windowed, so internally they are considered windowed, though there is no reason that has to be true. It's mostly historical but a lot of work to change.
(Reporter)

Comment 16

6 years ago
> On Mac we have the problem that we don't allow windowed plugins to be instantiated in popups at all

I'm confused.  I see flash video in the flyout popups, it just doesn't refresh the frames (per comment #1)
Attachment #685590 - Flags: review?(tnikkel) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/c94aecc61d74

Please file a separate bug for problems on Mac. That is likely a different problem than the one I'm fixing here. Sorry for hijacking the bug!
OS: All → Windows 7
https://hg.mozilla.org/mozilla-central/rev/c94aecc61d74
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.