account manager: the account that has focus when the Account Settings dialog is opened should be expanded and other accounts closed

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
18 years ago
7 years ago

People

(Reporter: sspitzer, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

fix account manager ui to take advantage of twisties

perhaps:

1) make it so all accounts are collapsed except for the currently selected
account.
2) make it so selecting an account expands it, and closes the others
3) continue to make it so we select the currect account when opening the dialog
Depends on: 63411
Hardware: PC → All

Comment 1

18 years ago
Don't implement/modify the current behaviour of widgets - like #2, this would
confuse the user. 

Clicking on a twisty or doubleclicking on its row should collapse its subitems -
no more, no less.

Comment 2

18 years ago
Agree. The twisties should work the same as in Preferences.  The account that 
has focus when the Account Settings dialog is opened should be expanded and 
other accounts closed.

"Clicking on a twisty or doubleclicking on its row should collapse its subitems 
- no more, no less."

Comment 3

18 years ago
I'd like to consider this for 0.9.2.  With all of the panels in the account
manager now, good twisty management would be nice.
Keywords: nsbeta1
Priority: -- → P3
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.2

Comment 4

18 years ago
moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 5

18 years ago
moving to 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 6

18 years ago
at the triage meeting today we were pretty sure this bug got fixed by some
eClient folks recently. Twisties seem to be working in the account manager on a
recent build. Re-open if I'm closing this under incorrect pretenses.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
I don't believe this is fixed, at all.  Seth did the twisties, but I'm pretty 
sure he filed this after the fact, to cover implementations not yet done.
QA Contact: esther → nbaca
reopen.  sorry, the subject is too vague.

here's one thing I'd (and jglick) like to see:

"The account that has focus when the Account Settings dialog is opened should 
be expanded and other accounts closed."
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
moving to 1.0, this is UI polish
Target Milestone: mozilla0.9.4 → mozilla1.0
updating summary.
Summary: fix account manager ui to take advantage of twisties → account manager: the account that has focus when the Account Settings dialog is opened should be expanded and other accounts closed

Updated

17 years ago
Blocks: 104166

Updated

17 years ago
Keywords: nsbeta1+
Whiteboard: [nsbeta1+]

Updated

17 years ago
Blocks: 122274
Status: REOPENED → ASSIGNED
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2

Updated

17 years ago
Blocks: 154249
mass re-assign.
Assignee: racham → sspitzer
Status: ASSIGNED → NEW

Comment 12

16 years ago
*** Bug 145618 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail

Comment 13

12 years ago
INVALID?

The selected account is expanded, which IMO is the only thing that matters. 
What's important about collapsing the other accounts?
Severity: normal → enhancement
QA Contact: nbaca
Or rather WONTFIX...
Target Milestone: mozilla1.2alpha → ---
Priority: P3 → --

Comment 15

7 years ago
> Or rather WONTFIX...
Sure.
Status: NEW → RESOLVED
Last Resolved: 18 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.