Closed Bug 802027 Opened 8 years ago Closed 8 years ago

"Homescreen had a problem and closed" when installing app "The Pomodoro Technique Timer"

Categories

(Firefox OS Graveyard :: General, defect, P1)

All
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+)

RESOLVED WORKSFORME
blocking-basecamp +

People

(Reporter: adora, Assigned: fabrice)

References

Details

(Keywords: crash, reproducible)

This just happened to me twice in a row.  The first time, I didn't see the homescreen error, but the screen went black and flashed a few times.  Deleted the app and rebooted.  The 2nd time, I saw the specific homescreen error.  

Both times after installing the app, tapping the icon has no response.

I'm able to install and launch other apps without error.
"FlipClock" seems to be experiencing the same issue.
And "OK! Magazine UK"
Reproducible I'm guessing? Can you reproduce it with the same app repeatedly?
blocking-basecamp: --- → ?
Yep!
Are these crashes being submitted? Can we get a stack for them?
How do I do that?
Not sure the setup is done yet for that. cjones?
Severity: normal → critical
(In reply to Andreas Gal :gal from comment #7)
> Not sure the setup is done yet for that. cjones?

The UI is not there yet but for now we send content and chrome crashes as soon as we have network connectivity after restart.
possibly the same bug with Dabr.eu app - except that in this case the homescreen keeps crashing on a loop until I restart the phone.
Very similar behavior when installing http://bit.ly/QmZVTg from Bug 796820.  So perhaps this has something to do with appcache.
Lisa, if all the apps that you find that cause this have appcache_path in their manifests, can you dupe this to 796820?  Thanks.
blocking-basecamp: ? → +
Not sure if I'm right or not... 

looks like : 10-18 10:39:31.748: E/GeckoConsole(1134): [JavaScript Error: "can't access dead object" {file: "chrome://browser/content/forms.js" line: 49}]

and OOM:
10-18 10:39:41.147: I/IdleService(413): Reset idle timeout: tell observer 4794f490 user is back
10-18 10:39:41.988: E/GeckoConsole(413): GC(T+1088.0) Total Time: 210.6ms, Compartments Collected: 1, Total Compartments: 101, MMU (20ms): 0%, MMU (50ms): 0%, SCC Sweep Total: 66.0ms, SCC Sweep Max Pause: 64.4ms, Reason: TOO_MUCH_MALLOC, Nonincremental Reason: malloc bytes trigger, Allocated: 13MB, +Chunks: 4, -Chunks: 0


Full logcat in gist : https://gist.github.com/3913644
Assignee: nobody → fabrice
Severity: critical → normal
Priority: -- → P1
The issue disappears with the patch from bug 795164 applied. This is not surprising since I was seeing lots of "Remove dead MessageManager!" before so I built with 795164.
Depends on: 795164
I tested again with today's daily build and can't reproduce anymore. Can someone from QA double check?
Keywords: qawanted
I can't reproduce either. Definitely seeing performance issues with the homescreen, but that's a separate bug. 

I do note I was seeing crashes a few days earlier with the homescreen, so something tells me something got fixed. Marking as worksforme.
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.