The default bug view has changed. See this FAQ.

Allow users to change "translation source" settings

RESOLVED FIXED

Status

Mozilla Developer Network
Localization
P2
critical
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: ghost@ethertank.jp, Assigned: jezdez)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4



Actual results:

If wrong "Translation source" are set to pages, We can't fix this.


Expected results:

We should be able to fix this.
(Reporter)

Updated

5 years ago
Severity: normal → major
Priority: -- → P2
(Reporter)

Updated

5 years ago
Severity: major → critical
Priority: P2 → P5
(Reporter)

Comment 1

4 years ago
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/String/quote
David: Does this sound like it's related to the other translation work that has been done recently?
No -- the translation source field was meant to only display if none is set.  Editing that field wasn't meant to be done upon implementation, so this is more of an enhancement than a bug.
Summary: Kuma: We can't change the "translation source" settings. → Allow users to change "translation source" settings

Updated

4 years ago
Component: Editing → Localization
Priority: P5 → P4
(Reporter)

Updated

4 years ago
Priority: P4 → P5
(Reporter)

Comment 4

4 years ago
This problem has become more serious, because administrator doing a lot of page-move operation.
If that's the case you want to bump this priority up to P3 or P2. :)
Priority: P5 → P2
(Reporter)

Comment 6

4 years ago
(In reply to Luke Crouch [:groovecoder] from comment #5)
> If that's the case you want to bump this priority up to P3 or P2. :)

Thanks for help.
I'm very helpless in this issue.
See also bug 872731. Not quite a dupe but we might fix both at the same time.
(Assignee)

Updated

4 years ago
Assignee: nobody → jezdez
(Assignee)

Updated

4 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Just a process nitpick.

This card was marked as "Ready" in the "Review & QA" problem, but that would mean it has been reviewed and is "Ready" for the next column. I removed the checkmark for now.

Comment 9

4 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/f884c795ab1061f191aa02695f38afe4d7162f43
fix bug 802041 - allow all users to change the translation sources of wiki documents.

https://github.com/mozilla/kuma/commit/355659c584ce54c803d7158d9a889bdf51235fc8
Merge pull request #1222 from jezdez/bug802041

allow all users to change the translation sources of wiki documents

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.