[Video] Can't launch anymore if the headset is plugged in before the video app is launched.

VERIFIED FIXED

Status

Firefox OS
Gaia
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: John Shih, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

2.46 KB, text/plain
Details
(Reporter)

Description

5 years ago
## Environment :
Otoro phone, build 2012-10-16
Build info: 
* "gaia" revision= 6a6c070293c6cd404fc7d3d7afece401dd114419
* "gecko" revision= add440caf2f26a55f86e456502689709a9fed143

## Repro :
1. Launch the video app from homescreen

## Expected:
* The app will be launched

## Actual:
* Only see the black screen

## Note:
* It works fine if launch the app first, then plug in the headphone
(Reporter)

Updated

5 years ago
Severity: normal → blocker
blocking-basecamp: --- → ?
This sounds a bit similar to Bug 801980.
10-16 10:36:00.451: E/GeckoConsole(106): Content JS INFO at app://system.gaiamobile.org/js/window_manager.js:805 in createFrame: %%%%% Launching Video as remote (OOP)
10-16 10:36:00.491: E/GeckoConsole(106): Content JS LOG at app://system.gaiamobile.org/js/window_manager.js:386 in anonymous: Window Manager: No screenshot in database. This is expected from a fresh installed app.
10-16 10:36:01.011: E/profiler(1038): Registering start signal
: E/(): Device disconnected


Device rebooted; this is with the headphones plugged in before launching the video app.  I can repro this after reboot as well.  I think it might have to do with kernel 10.
Summary: [Video] Can't launch anymore → [Video] Can't launch anymore if the headset is plugged in before the video app is launched.
Fabrice says that we have a similar issue with radio
blocking-basecamp: ? → +
Priority: -- → P1
Yes, I think this is a dupe of bug 800263, and this may mean that the issue is with the sound subsystem and not with the apps themselves.
(Reporter)

Comment 5

5 years ago
Created attachment 672657 [details]
logcat

attach the log of launching the video
Michael, can you investigate?
Assignee: nobody → mwu
Severity: blocker → normal

Comment 7

5 years ago
I am not familiar with this code/issue. CC'ing some people who may have ideas.
Assignee: mwu → nobody
Depends on: 800263
(Reporter)

Comment 8

5 years ago
I can't reproduce now
actually it more like bug 801980 and has to do with SD card
close it now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
Component: General → Gaia
You need to log in before you can comment on or make changes to this bug.