Can not add, change or confirm event with tabs in the description

RESOLVED DUPLICATE of bug 686833

Status

RESOLVED DUPLICATE of bug 686833
6 years ago
6 years ago

People

(Reporter: tb4, Unassigned)

Tracking

Lightning 1.8

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 671770 [details]
TabTestcase.ics

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

Add (manually or by import) or edit an event with tabs in the description. The description was pasted from the original invitation, which could not be accepted, because of exactly the same reason.

The calendar is a CalDAV calendar (Debian; calendarserver).

[ Windows 7 64b, TB 16.0.1, Lightning 1.8 ]


Actual results:

The modification did not happen. Instead an error message popped up (pasted this from error console):

Error: An error occurred when writing to the calendar <Calendar name>!
Error code: MODIFICATION_FAILED.
Description: Status Code: 403, The user lacks the required permission to perform the request.


<?xml version='1.0' encoding='UTF-8'?><error xmlns='DAV:'>
  <valid-calendar-data xmlns='urn:ietf:params:xml:ns:caldav'/>
  <error-description xmlns='http://twistedmatrix.com/xml_namespace/dav/'>Can't parse calendar data</error-description>
</error>
Source File: resource://calendar/modules/calUtils.jsm -> file:///D:/Data/Mozilla/Thunderbird/default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Line: 1071


Expected results:

The event should have been added/updated.

By saving the .ics file and replacing the tabs by spaces, the event can be imported.

Note that when the confirmation is done from Outlook (other user...) the event could be added to the calendar and Lightning can read and display that event. So it seems that only posting is affected.
(Reporter)

Comment 1

6 years ago
When replacing the tabs by "\t" in the .ics file, the event can also be imported into the calendar, with tabs in the intended locations.

Comment 2

6 years ago
Hi. Thanks for reporting the bug. This is a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686833
You need to log in before you can comment on or make changes to this bug.