All users were logged out of Bugzilla on October 13th, 2018

I have lost all my email accounts in the mail sector when I upgrade the Sea Monkey Browser

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
6 years ago
5 years ago

People

(Reporter: mrwineuk, Unassigned)

Tracking

SeaMonkey 2.13 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20120909 Firefox/15.0.1 SeaMonkey/2.12.1
Build ID: 20120909051100

Steps to reproduce:

You upgraded my Sea Monkey Browser


Actual results:

All my Mail server accounts failed to reload  This has happened on two different computers. I have managed to get the local folders to reappear after getting rid of a new folder that said local folders-1


Expected results:

They should have re-appeared

Comment 1

6 years ago
Current SeaMonkey version is 2.13.1, you write from 2.12.1, from which and to which version you upgraded?
Whiteboard: closeme INCO 2012-11-01
(Reporter)

Comment 2

6 years ago
It is 2.13.1 now. I had to upload the previous version around about 30th August h2001 there are about 21 email accounts in it which I had to manually over 4 days put in then as I put a new hard drive in my laptop. Some emails date back to 2008 and are evidence in legal cases as I am a lawyer. Although I can see them in explorer I can not get them this time. I had this once before on another computer and since have not upgraded Sea Monkey. This time it upgraded by itself. I do not get this problem with Thunderbird

Comment 3

6 years ago
A couple of old "fixed" bug, but maybe something there will stand out?

Bug 534382 - TB stores new fetched e-mails in Local Folders-1 after upgrade...

Bug 538414 - Recover mail downloaded to Local Folders-1

Comment 4

6 years ago
Ah our migration/update code has problems if the profiles/data are not on drive C:. I think prefs.js needs to be hand edited. Each account server has a relative path and an absolute path stored in prefs.js. In our profile code relative paths take precedence which of course don't work if the profile is on another drive.

If I remember correctly deleting the pref for the relative path should make SeaMonkey use the pref which stores the path to your mail files as an absloute path.

Comment 6

6 years ago
> Another report, http://forums.mozillazine.org/viewtopic.php?f=40&t=2586725
=>NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Whiteboard: closeme INCO 2012-11-01
Version: SeaMonkey 2.12 Branch → SeaMonkey 2.13 Branch

Comment 7

5 years ago
Do you still see this problem on upgrades?
Flags: needinfo?(mrwineuk)
Whiteboard: closeme INCO 2014-04-01

Comment 8

5 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mrwineuk)
Resolution: --- → INCOMPLETE
Whiteboard: closeme INCO 2014-04-01
You need to log in before you can comment on or make changes to this bug.