[Media Storage] TypeError: dsfile.lastModifiedDate is null

RESOLVED FIXED

Status

Firefox OS
Gaia
P2
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ttaubert, Assigned: ttaubert)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: QARegressExclude)

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
I recently started seeing this error:

Error: TypeError: dsfile.lastModifiedDate is null
Source File: app://gallery.gaiamobile.org/shared/js/mediadb.js
Line: 991

Easy to fix but this causes mediadb scans to fail and for example the gallery doesn't stop loading.
(Assignee)

Comment 1

6 years ago
Created attachment 671797 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5839

Pointer to Github pull-request
(Assignee)

Updated

6 years ago
Attachment #671797 - Flags: review?(dflanagan)
Comment on attachment 671797 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5839

r=me but see the review comments on github
Attachment #671797 - Flags: review?(dflanagan) → review+
(Assignee)

Comment 3

6 years ago
Comment on attachment 671797 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5839

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Workaround for bug 793955.
User impact if declined: MediaDB does not scan or is interrupted.
Testing completed: 
Risk to taking this patch (and alternatives if risky): Low risk.
Attachment #671797 - Flags: approval-gaia-master?
(Assignee)

Updated

6 years ago
Attachment #671797 - Flags: approval-gaia-master? → approval-gaia-master?(21)
Comment on attachment 671797 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5839

Low risk. a=me.
Attachment #671797 - Flags: approval-gaia-master?(21) → approval-gaia-master+
(Assignee)

Comment 5

6 years ago
https://github.com/mozilla-b2g/gaia/commit/2f66c8a95d9dd400eba7b51b88a357b4b8a87adf
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
blocking-basecamp: ? → +
Priority: -- → P2

Updated

6 years ago
Whiteboard: QARegressExclude
You need to log in before you can comment on or make changes to this bug.