[dev] Searching for name, irc nick, or email address does not return any results

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: mbrandt, Assigned: giorgos)

Tracking

Details

(Whiteboard: [fromAutomation], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 671896 [details]
qa - no results returned bug

This appears to only be on dev and was caught by out suite of Selenium driven tests (yay for automated tests).

Steps to reproduce:
1. goto dev and login with a vouched account
2. search for a user that is known to be in the system (Matt, William, Aakash) using their name, nick, or email address.

Expected:
Results are returned

Actual:
Results are not returned. 3 tests in Web QA's Jenkins CI are failing
http://qa-selenium.mv.mozilla.com:8080/job/mozillians.dev/2288/testReport/

Updated

6 years ago
Assignee: nobody → giorgos
(Assignee)

Comment 2

6 years ago
We changed the index structure so we had to re-index all data (see bug 801956). Unfortunately it's still not working. I'm in engagement off-site and I'll be looking into this as soon as i've got some free time.
(Reporter)

Comment 3

6 years ago
Giorgos, thank you for looking into it (I know your team is busy) -- I've xfailed the offended tests in our (and your) test suite.

https://github.com/mozilla/mozillians-tests/commit/eeb1108653d40fd6d6efb6a5c5e786edbfd2f14b

Updated

6 years ago
Depends on: 804517
(Assignee)

Comment 4

6 years ago
I'm closing this one as fixed since we resolved all the elastic search issues and manually tested it. 

Thanks!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
Hot -- bumping to verified -- tested manually as well.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.