[settings] Volume/Brightness slider hard to control with drag function

RESOLVED WORKSFORME

Status

defect
P3
normal
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: epang, Unassigned)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18-v1.0.1 affected)

Details

(Whiteboard: visual design, testrun 4 inarirun1)

Attachments

(1 attachment)

when dragging the handle feels sticky and doesn't follow my finger. (for example, volume and brightness).
That's some bad UX. It seems really hard (if not impossible most of the time) to exactly hit the button so that you can drag it around. I think no matter where the dragging starts we should always move the handle to the finger and let it then follow the finger.
Component: Gaia → Gaia::Settings
The touch targets are too small.
When touched the entire section is highlighted (wrong) and likely competes with the touch target of the component.
And the highlight state circle should be larger.
Priority: -- → P3
Just a quick note that I ran into this today. It is really difficult to grab the knob of the slider.

A couple of things happen when I try to grab it:

* The row that contains the slider is highlighted
* The list of settings scrolls vertically
Ran test today and same issue persists.  Using build 2012121707020
This issue still reproduces on Unagi device,
Build ID: 20130125070201
Kernel: Dec 5
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18/rev/94a2d6fcdfde
Gaia:   6369dbf33b622faf4b4d176fed30b77c5c319dfc

This bug fails TC #2902
https://moztrap.mozilla.org/runtests/run/702/env/296/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=2902
OS: Other → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: visual design → visual design, testrun 3
This issue still reproduces on Unagi device.
Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9

UCID: set-119
TC: #2902
https://moztrap.mozilla.org/runtests/run/712/env/296/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=2902
Whiteboard: visual design, testrun 3 → visual design, testrun 4
Duplicate of this bug: 817668
Tested on 19-03-2013 build of gaia/master and I'm still able to reproduce this bug.  The scroll works when tapped but the handle is very difficult to grab and drag.  This bug seems to be apparent for all sliders in settings.  The music player bar is a good example of how the slider should function.
blocking-b2g: --- → koi?
Issue reproduces on Inari Device.

Build ID: 20130417070205

Environmental  Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6bac24e14538
Gaia: 2d048a9bdae54e4ec7d48326c2130591c8b869b6

UCID- set-074
Link to failed test case: https://moztrap.mozilla.org/runtests/run/1105/env/316/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=1400

The slider doesn't function all the time. Adjusting brightness can be difficult. User may have to tap on the bar a few times in order to slide it.
Whiteboard: visual design, testrun 4 → visual design, testrun 4 inarirun1
Volume/Brightness slider does not work at all with drag function on Leo 
Build ID: 20130722070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia: 41d10fb10be6916e6554eb440d9a97130ef23ce0
Platform Version: 18.1
RIL Version: 01.01.00.019.164 

related to bug 896594
Not +'ing polishing bug. Feel free to ask for approval.
blocking-b2g: koi? → -
Facing similar issue with Tablet on current build. Filed another bug[1] for that, because that is just about increasing the height of slider as quick fix.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1066408
Tested with master today, it went quite smooth. Is this still an issue?

Gaia: a7dcc5fb595030dab140d5ff0e7eb5ef04017d51
Gecko: https://hg.mozilla.org/mozilla-central/rev/946ac85af8f4
Flags: needinfo?(epang)
No longer blocks: 1094010
(In reply to Ting-Yu Chou [:ting] from comment #15)
> Tested with master today, it went quite smooth. Is this still an issue?
> 
> Gaia: a7dcc5fb595030dab140d5ff0e7eb5ef04017d51
> Gecko: https://hg.mozilla.org/mozilla-central/rev/946ac85af8f4

thanks for checking in.  No this was a very long time ago and can be closed!  :)
Flags: needinfo?(epang)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.