back/forward buttons skip search results

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: Pierre Fortin, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121013030542

Steps to reproduce:

1. Open tab
2. google.com
3. enter search (i.e., unc chapel hill dental clinic)
4. follow link
5. Back -- goes back to empty search page (#2 above)
6. Forward -- goes to previous site ((#4 above)

Holding Back/Forward shows results page; but Back/Forward jump right over it.


Actual results:

Had to manually override B/F buttons to get search results. 


Expected results:

Follow history.

Comment 1

6 years ago
WFM here on Win 7 with FF19.

Comment 2

6 years ago
In 20121023030553 Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0:
* links from Google search results open in new tabs;
* if I click Images, Back works;
* if I click Docs or Mail, a redirect to accounts.google.com happens; Back loads docs.google.com, so is useless.

Could be related to bug 323922?

Comment 3

6 years ago
(In reply to Aleksej [:Aleksej] from comment #2)
> * if I click Docs or Mail, a redirect to accounts.google.com happens; Back
> loads docs.google.com, so is useless.

That is bug 788497 / bug 606286.
WFM on Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0b3
(Reporter)

Comment 5

5 years ago
Seems to be back on 23.0a1 (2013-05-06) on Linux64

To reproduce, http://google.com, search for "mantra", click on a link, then click the back button...  blank page.
Unable to reproduce on 23.0a1 (2013-05-07) Ubuntu 12.04 x64.
I'm pretty sure one of your addons is causing the trouble. Please try to reproduce in safe mode: http://support.mozilla.com/kb/Safe+Mode
(Reporter)

Comment 7

5 years ago
This bug is random...   just had it happen again on 24.0a1 (2013-05-30) -- only on google search results page.

Had it happen on one tab.  Tried the same search and link follow on other new tabs without problem.  Yet, back to the tab with the issue and I could Forward/Back over and over, always getting a blank page where the google search results should be.  All the other tabs I opened trying to reproduce would not trigger the bug which stayed on the first tab until I reloaded it & cleared the bug...

Impossible, so far, to reproduce.
(Reporter)

Comment 8

5 years ago
replacing with but 878456
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.