Keyboard is not to design spec.

VERIFIED FIXED

Status

Firefox OS
Gaia::Keyboard
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: jrmuizel, Assigned: patryk)

Tracking

unspecified
Other
Mac OS X

Firefox Tracking Flags

(b2g18 verified)

Details

(Whiteboard: visual design, incorrect implementation, UX-P2, uxbranch, landed in uxbranch, qa-verified)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 671993 [details]
Screenshot

If you look at the Copyright or Registered symbols they look really bad and are nearly unreadable.

We should either use a real bold font or not use bold.

Comment 1

6 years ago
Patryk, we either need the CSS issue resolved today, or we have to revert to the old font. We can't be stuck in this half way mess.
(Assignee)

Updated

6 years ago
Assignee: nobody → padamczyk

Comment 2

6 years ago
In a related note, E.me's fonts look terrible. Is that the system font doing synth bolding?
(In reply to Andreas Gal :gal from comment #2)
> In a related note, E.me's fonts look terrible. Is that the system font doing
> synth bolding?

Yeah, it's the default system font, MozTT. I am told that we will not be supplied with a true MozTT Bold font.

Comment 4

6 years ago
Can we use medium as bold? Because it looks disastrous right now.
(Assignee)

Comment 5

6 years ago
(In reply to Andreas Gal :gal from comment #4)
> Can we use medium as bold? Because it looks disastrous right now.

Yes, switched it to medium, just want to test it first
(In reply to Patryk Adamczyk [:patryk] UX from comment #5)
> (In reply to Andreas Gal :gal from comment #4)
> > Can we use medium as bold? Because it looks disastrous right now.
> 
> Yes, switched it to medium, just want to test it first

I am not sure what Andreas proposed is

1) rewrite font-weight CSS across entire Gaia, change Bold to Medium, or,
2) Reassign MozTT Medium to |font-weight: bold|

Keep in mind that we really cannot rewrite the entire web not to use |font-weight: bold|, so if we do (1) then MozTT should not be the default font for everything.

Comment 7

6 years ago
My suggestion would be 2). I agree if we can't solve this generally, we shouldn't use MozTT as default font.
(Assignee)

Updated

6 years ago
See Also: → bug 804109
(In reply to Andreas Gal :gal from comment #7)
> My suggestion would be 2). I agree if we can't solve this generally, we
> shouldn't use MozTT as default font.

MozTT bold is available on bug 804109, \o/

Making this depend to that. We can close this issue if the new font looks good.
Depends on: 804109
(Assignee)

Comment 9

6 years ago
(In reply to Andreas Gal :gal from comment #7)
> My suggestion would be 2). I agree if we can't solve this generally, we
> shouldn't use MozTT as default font.

2 Issues.

1. Webfonts generally have 2 weights. Normal & Bold. The css has BOLD specified in a few instances, and since we don't have BOLD its making the fonts looks ugly. https://bugzilla.mozilla.org/show_bug.cgi?id=804109 will add the BOLD version of MozTT (which is medium, just renamed to BOLD). So this ugly faux bold issue will be solved.
2. We need to change the CSS tags that specify font-weight: 600 or bold to 500, as when we do finally add a true bold in v.2 we don't want everything to get super fat.
(Assignee)

Comment 10

6 years ago
https://github.com/mozilla-b2g/gaia/pull/5927 fixes the ugly font.
But the sizing needs to be adjusted, see the screenshots. http://cl.ly/image/3K2Z023u3m0A
(Assignee)

Comment 11

6 years ago
Created attachment 674168 [details]
Keyboard Phone Spec (updated sizing for the new font)

Font Size Matrix
1  pt = 0.3528 mozmm =  2.2918 px  
6.5pt = 2.2932 mozmm = 14.8966 px 
9  pt = 3.1752 mozmm = 20.6260 px
10 pt = 3.5278 mozmm = 22.9180 px
20 pt = 7.0556 mozmm = 45.8360 px


1em = 15px
6.496 px / mm on a 165ppi resolution
(Assignee)

Updated

6 years ago
Assignee: padamczyk → timdream+bugs
(Assignee)

Comment 12

6 years ago
Created attachment 674208 [details]
Keyboard Phone Spec (updated sizing for the new font)

Font Sizes
1  pt = 0.3528 mozmm =  2.2918 px =  0.23rem  
6.5pt = 2.2932 mozmm = 14.8966 px =  1.49 rem
9  pt = 3.1752 mozmm = 20.6260 px =  2.06 rem
10 pt = 3.5278 mozmm = 22.9180 px =  2.29 rem
20 pt = 7.0556 mozmm = 45.8360 px =  4.58 rem


1em = 10px
6.496 px / mm
Attachment #674168 - Attachment is obsolete: true
(Assignee)

Comment 13

6 years ago
The bold font has been fixed but some font size adjustments are still required.
Assignee: timdream+bugs → padamczyk
Keywords: polish
Whiteboard: visual design, incorrect implementation
(Assignee)

Updated

6 years ago
Priority: -- → P3

Updated

6 years ago
Component: Gaia → Gaia::System::Keyboard
(Assignee)

Updated

6 years ago
Summary: Keyboard synth bold font looks bad → Keyboard is not to design spec.
(Assignee)

Updated

6 years ago
Priority: P3 → P2
(Assignee)

Updated

6 years ago
Duplicate of this bug: 815371
(Assignee)

Updated

6 years ago
Keywords: polish
(Assignee)

Updated

6 years ago
Assignee: padamczyk → gbrander
(Assignee)

Comment 15

6 years ago
Created attachment 687217 [details]
Can you please move the baseline of all the keys down 2px?

Gordon, I know you're doing a lot of keyboard work, so I don't want to mess up your changes.
(Assignee)

Updated

6 years ago
Whiteboard: visual design, incorrect implementation → visual design, incorrect implementation UX-P2
(Assignee)

Updated

5 years ago
Assignee: gbrander → padamczyk
Whiteboard: visual design, incorrect implementation UX-P2 → visual design, incorrect implementation, UX-P2, uxbranch
(Assignee)

Comment 16

5 years ago
Created attachment 698661 [details]
before / after

Comment 17

5 years ago
Landed in UX Branch https://github.com/gordonbrander/gaia/commit/a843882e15d38a27cf4c309924bcac788cfce245
Whiteboard: visual design, incorrect implementation, UX-P2, uxbranch → visual design, incorrect implementation, UX-P2, uxbranch, landed in uxbranch
I see the change, it doesn't seem to make that huge of a dent in terms of the readability for the copyright symbol to me.

There doesn't seem to be any break of the keyboards... seems to fit just fine.
Spoke with Patryk.  We're good on this... marking qa-verified
Whiteboard: visual design, incorrect implementation, UX-P2, uxbranch, landed in uxbranch → visual design, incorrect implementation, UX-P2, uxbranch, landed in uxbranch, qa-verified
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/dec694d585e1
Gaia   5a31a56b96a8fc559232d35dabf20411b9c2ca1d
BuildID 20130325070203
Version 18.0
unagi 

Can't verify in master due to bug 854138
status-b2g18: --- → verified
Oh I see why I put the wrong comment in this bug.  It's because the pull request was the only thing I looked at at the time.  The pull request id was incorrect.  Checked the code and they were both in master and v1train.

Master build : 2013-03-26-07-02-04
"mozilla-central" revision="28b048ffb7a7"
"integration/gaia-central" revision="44f6a17f24d4"
"gecko.git"revision="a800f14ea7022a78966f7fe14a9b0d11c569b151"
"gaia.git" revision="ace1eb32a313da1232bbdf9cff2581a4b036356d"

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/28b048ffb7a7
Gaia   ace1eb32a313da1232bbdf9cff2581a4b036356d
BuildID 20130326070204
Version 18.0
Unagi
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.