If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Core
IPC
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: espindola, Assigned: espindola)

Tracking

unspecified
mozilla19
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox18 fixed)

Details

Attachments

(1 attachment)

Created attachment 672047 [details] [diff] [review]
cast via intptr_t

Newer clangs have this warning:

error: cast to 'void *' from smaller integer type 'int'

which in combination with -Werror causes the build to fail without this patch. I don't know the code, so I am assuming that the value is not actually a pointer, it is just being casted to one to fit in an old existing API, is that the case?
Attachment #672047 - Flags: review?(bgirard)
Blocks: 799572

Updated

5 years ago
Attachment #672047 - Flags: review?(bgirard) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/c33b8a63580c
https://hg.mozilla.org/mozilla-central/rev/c33b8a63580c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Comment on attachment 672047 [details] [diff] [review]
cast via intptr_t

This is needed for bug 799572.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #672047 - Flags: approval-mozilla-aurora?
Comment on attachment 672047 [details] [diff] [review]
cast via intptr_t

Approving as it is needed by 799572
Attachment #672047 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 5

5 years ago
Pushed to Aurora:
http://hg.mozilla.org/releases/mozilla-aurora/rev/3e9a1114bd92
status-firefox18: --- → fixed
You need to log in before you can comment on or make changes to this bug.