Closed Bug 8025 Opened 21 years ago Closed 10 years ago

[FEATURE] Integrate mail/news wizard into profile wizard

Categories

(SeaMonkey :: MailNews: Account Configuration, enhancement, P4)

All
Other
enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: selmer, Unassigned)

References

Details

The new plan is that the profile wizard will instantiate the mail wizard to fill
in the initial settings when the profile is created.  Since their wizard will be
designed to handle multiple mail accounts, we should get that for free under the
new plan.  That's scheduled to come in for M8.  Marking this bug for M9 unless
tighter coordination is discovered to be possible.
Status: NEW → ASSIGNED
Target Milestone: M9
Target Milestone: M9 → M10
Moving the target fix version to M10.
P3s aren't going to make it in M10.  Bulk moving to M11.
Blocks: 12696
Summary: Integrate mail/news wizard into profile wizard → [FEATURE] Integrate mail/news wizard into profile wizard
Added [FEATURE] to summary.
Assignee: gayatrib → alecf
Status: ASSIGNED → NEW
Reassigning to Alec as mailnews wizard is in his plate.
Component: Profile Manager → Localization
Product: Browser → MailNews
Changing product to mailnews.
Component: Localization → Profile Manager
Blocks: 11091
(target milestone is M11 or M12 - add to beta tracking bug)
No longer blocks: 12696
Not a profile manager tracker, removing from the PM tracking bug.
Component: Profile Manager → Front End
(I'm temporarily changing the component to Front End since we can't have any
existing bugs when I change Profile Manager component to Account Setup
component.)
Status: NEW → ASSIGNED
Target Milestone: M11 → M14
Hrm. This doesn't really need to be fixed for PR1, since:
1) we aren't doing webmail for PR1, so this doesn't have to be synced
w/netcenter
2) the account dialog will come up automatically if there are no accounts when
you open messenger.

Since this requires signifigant changes to the account wizard, I'm moving this
to post PR1.
No longer blocks: 11091
Component: Front End → Account Manager
Target Milestone: M14 → M15
Depends on: 24460
Target Milestone: M15 → M17
Do we really need to do this? Seems like a reasonable simplification to leave it
as it is (mail account wizard not connected to profile wizard)
The thing we lose is the ability for the user to set up their mail information 
at the same time they create the profile.  I think we've generally converged on 
not wanting that very much anymore.  Perhaps this should move to help wanted. 
P4 per m/n staff mtg today
Priority: P3 → P4
[FEATURE] bugs past M16 are OUT for this release.  Marking M20.  If you disagree 
with this action, please help me explain it to the PDT.
Target Milestone: M17 → M20
Moving feature bugs to target milestone "Future" for next release consideration.
Severity: normal → enhancement
Target Milestone: M20 → Future
massive reassign of account manager bugs -> sspitzer
please feel free to put me back on the CC if you have any questions/comments
Assignee: alecf → sspitzer
Status: ASSIGNED → NEW
mass re-assign of account manager bugs to racham.
Assignee: sspitzer → racham
Just curious- since this hasn't been touched for 1.25 yr (and not discussed for
two years), what's the status of this bug? Is it a WONTFIX as per comment 10? Or
will it be fixed sometime in the post-1.0 stage?
Daniel, we sometimes have enhancement/future bugs as a way to say "we wouldn't
mind having this, but we're not going to work on it anytime soon."  If we close
it wontfix, that would mean that we wouldn't want this even if a patch were
available.  That _may_ be the right answer, but I don't think it would be
related to the age of the bug.
mass re-assign.
Assignee: racham → sspitzer
Product: Browser → Seamonkey
Assignee: sspitzer → mail
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → EXPIRED
Explicitly WONTFIXing.
Resolution: EXPIRED → WONTFIX
You need to log in before you can comment on or make changes to this bug.