Freeze of Firefox when selecting 'List Cache Entries' for the disk cache in 'about:cache'

RESOLVED WORKSFORME

Status

()

Core
Networking: Cache
--
critical
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({hang})

19 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121015042010

When I'm trying to open the list of disk cache items Firefox freezes.

Steps:
1. Browser for a while to have a lot of entries in the cache. In my case it was about 800MB and more than 28000 entries
2. Open 'about:cache' and click 'List Cache Entries' for the disk cache

Firefox will freeze immediately. I'm not sure if it comes back, I had to force quit after about 5 minutes.

Comment 1

5 years ago
Is this a regression from the stuff that I've done recently?  If yes, I need more details.
(Reporter)

Comment 2

5 years ago
I do not have the time currently to do a full test here. Anthony, would you mind finding a person? What you will need is a Firefox instance which is running for a long time.
Keywords: qawanted
Seems to me like this is a dupe of bug 165821, unless it used to work for you, and only recently started hanging.
(Reporter)

Comment 4

5 years ago
Created attachment 672387 [details]
activity monitor sample

Not sure if the sample is helpful but I did it with a disk cache filled with 2211 entries and about 27244 KiB storage in use. It takes about 5 minutes and completely freezes Firefox. Are we using the main thread to load the data?
(In reply to Henrik Skupin (:whimboo) from comment #4)
> Created attachment 672387 [details]
> activity monitor sample
> 
> Not sure if the sample is helpful but I did it with a disk cache filled with
> 2211 entries and about 27244 KiB storage in use. It takes about 5 minutes
> and completely freezes Firefox. Are we using the main thread to load the
> data?

Yes, the main thread is used to iterate over all the cache entries in about:cache (which is why I think this is a dupe of bug 165821)
(Reporter)

Comment 6

5 years ago
So bug 165821 is about not using the main thread but it will probably not fix the problem that it takes so long to load the data. I do not see a bug about this specific issue. Would it make sense to keep this issue or shall we dupe and re-investigate later once the fix has checked-in?
Henrik I am not able to reproduce your initial issue on Nightly 19 from (2012-10-18) nor on Latest Nightly 27 using Mac OX 10.7.5.

Here are my information for about:cache section:

Number of entries: 	7502
Maximum storage size: 	538400 KiB
Storage in use: 	38089 KiB
Cache Directory: 	/Users/svuser/Library/Caches/Firefox/Profiles/94i87uia.default/Cache

Are you still encountering this issue on your local machine?
(In reply to Mihai Morar, QA (:MihaiMorar) from comment #7)

Unfortunately I don't have a dirtier profile now, but I can create one ASAP.
(Reporter)

Comment 9

4 years ago
(In reply to Mihai Morar, QA (:MihaiMorar) from comment #7)
> Number of entries: 	7502
> Maximum storage size: 	538400 KiB
> Storage in use: 	38089 KiB

You might want to put way more entries in the cache. 38MB is nothing and will be deleted instantly I assume. See my initial comment for a reference of entries and used cache.
Henrik is there a fast way to fill up cache using an automated script or something like that? I have used a simple JS script that opens lots of tabs but the problem is that I am using only about 20mb for one run.

for (var i=0;i<100;i++){
  var url = 'http://engadget.com';
  window.open(url); 
}

This is the script I had used but the problem is that it opens only 23 tabs (it doesn't matter if I set it to open 50, 100.. x tabs), and then I have to close them all and run again the script. I am not sure why Firefox is behave this way if I set it to open 100 tabs.
(Reporter)

Comment 11

4 years ago
I do not have a script, no. But you might want to work with websites which contain e.g. image galleries. Those will fill-up the cache faster than any other website.
(In reply to Mihai Morar, QA (:MihaiMorar) from comment #10)

I have also set browser.cache.disk.smart_size_cached_value and browser.cache.disk.capacity to 900000kb because they are set at 358400 as default.
I further investigated this issue on Aurora 18.0a2 and also on RC 18.0 under Mac OSX 10.7.5, but I was still unable to reproduce it using the following cache properties:

Number of entries: 47984
Maximum storage size: 900000 KiB
Storage in use: 789603 KiB
(In reply to Mihai Morar, QA (:MihaiMorar) from comment #13)
> I further investigated this issue on Aurora 18.0a2 and also on RC 18.0 under
> Mac OSX 10.7.5, but I was still unable to reproduce it using the following
> cache properties:
> 
> Number of entries: 47984
> Maximum storage size: 900000 KiB
> Storage in use: 789603 KiB

Henrik, is this issue still reproducible on your side? At this point, we're unable to replicate it under conditions such as the ones that you see above.
Flags: needinfo?(hskupin)
Keywords: qawanted
(Reporter)

Comment 15

3 years ago
Sorry for the late reply but this is no longer an issue of a recent Nightly build. Marking as WFM.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(hskupin)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.