Closed Bug 802550 Opened 9 years ago Closed 9 years ago

Should be able to clear recent history if "Never remember history" option is selected

Categories

(Firefox :: Menus, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 463607

People

(Reporter: pauly, Unassigned)

References

Details

STR:
1. Make sure "Remember history" pref is selected
2. Open couples of websites to make some history
3. Select "Never remember history"

Actual results:
"Tools/Clear recent history" option is grayed-out, even if the history list is not empty

Expected results:
"Tools/Clear recent history" option should be available until the history list gets empty
Duplicate of this bug: 587763
Basically it's disabled cause many services are doing the wrong thing on the command during pb mode.
Could be per window PB may change something there, or even make things worse.
I see. Thanks for explaining.
The thing is it's a little bit annoying that in order to get rid of the history I have to change a setting, then delete history and then return to the initial setting.
FWIW, when per-window private browsing mode is shipped, this and bug 463607 will be deprecated.  I don't think anyone has any plans on fixing bug 463607 until then, but anyway this is really a dupe of that bug.
Status: NEW → RESOLVED
Closed: 9 years ago
No longer depends on: 463607
Resolution: --- → DUPLICATE
Duplicate of bug: 463607
You need to log in before you can comment on or make changes to this bug.