Closed Bug 802581 Opened 8 years ago Closed 8 years ago

-moz-transform: rotate : in Firebug, the <span> box rotate, but the text do not follow into it

Categories

(Core :: Layout: Block and Inline, defect)

13 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: aricim, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I look at http://fr.wikisource.org/wiki/Mod%C3%A8le:Rotation
other users of this wiki also.


Actual results:

-moz-transform: rotate is not ok. In Firebug, I see the <span> box rotated, but the text do not follow into it. <i> or <span> do the same.
Seems a regression in Firefox 16.0.1 in MacOSX 10.6.8 because it is ok in Firefox 6.0.2.
I'm not sure it's a real regression, it's maybe designed according to the specs.
CC'ing devs for confirmation if it's valid or not.

m-c
good=2012-02-17
bad=2012-02-18
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2271cb92cc05&tochange=550779e6bab4

m-i
good=2012-02-15
bad=2012-02-16
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1db98753a46f&tochange=69cb70c3a1e9

Suspected bug:
Aryeh Gregor — Bug 722463 - Transforms should not work on non-replaced inline elements. r=roc
Blocks: 722463
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Block and Inline
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Version: 16 Branch → 13 Branch
Indeed.  Transforms do not apply to <span> or <i>, per spec, unless you style them as "inline-block" or "block".
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
It'is OK, thanks.
You need to log in before you can comment on or make changes to this bug.