about:home has misaligned/overlapping thumbnails on tablet

VERIFIED FIXED in Firefox 19

Status

()

VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: cwiiis, Assigned: wesj)

Tracking

Trunk
Firefox 19
ARM
Android
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox19 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
The thumbnails on about:home appear to be misaligned/sized on a 1024x600 tablet. They also don't appear to have great alignment on a Nexus 7 tablet, but this may be down to design.

1024x600 Honeycomb tablet (HTC Flyer): https://www.dropbox.com/s/0czq1hog0ontxdz/2012-10-17%2014.53.29.jpg
1280x800 Jellybean tablet (Nexus 7): http://cl.ly/image/1b2U0Q3P3C2C
(Assignee)

Comment 1

6 years ago
Hmm... I'll have to get a flyer to test.

I'm not sure what you mean by "don't appear to have a great alignment", but the mockups are at: http://www.flickr.com/photos/61892693@N03/7638102886/in/set-72157630730911182
(Reporter)

Comment 2

6 years ago
(In reply to Wesley Johnston (:wesj) from comment #1)
> Hmm... I'll have to get a flyer to test.

I suspect that this would be the same on an original Galaxy Tab, original Kindle Fire and the Galaxy Tab 7.0 / 7.0 II; these devices might be a little easier to get a hold of.

> I'm not sure what you mean by "don't appear to have a great alignment", but
> the mockups are at:
> http://www.flickr.com/photos/61892693@N03/7638102886/in/set-72157630730911182

They seem to be a bit more bunched up in the screenshot? The margins look larger and the spacing looks smaller - Also the spacing in the label text looks smaller too, but I guess that's a separate issue.
(In reply to Chris Lord [:cwiiis] from comment #2)
> I suspect that this would be the same on an original Galaxy Tab, original
> Kindle Fire and the Galaxy Tab 7.0 / 7.0 II; these devices might be a little
> easier to get a hold of.

Looks fine on the original Galaxy Tab (10.1" running honeycomb).
(Assignee)

Comment 4

6 years ago
And on the 10.1 running ICS. We have some Tab 7's around in MV I think.
(Reporter)

Comment 5

6 years ago
The original Galaxy Tab is a 7" device(In reply to Kartikaya Gupta (:kats) from comment #3)
> (In reply to Chris Lord [:cwiiis] from comment #2)
> > I suspect that this would be the same on an original Galaxy Tab, original
> > Kindle Fire and the Galaxy Tab 7.0 / 7.0 II; these devices might be a little
> > easier to get a hold of.
> 
> Looks fine on the original Galaxy Tab (10.1" running honeycomb).

The original Galaxy Tab is a 7" device with a 1024x600 screen, that's a Galaxy Tab 10.1.
(Assignee)

Comment 6

6 years ago
Yes. mfinkle has an original 7" tab (running froyo) and the thumbnails are fine.  I suspect the problem is in my implementation of getColumnWidth:

http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/AboutHomeContent.java.in#693

nhirata is bringing a flyer (with Gingerbread) by tomorrow to test. If it doesn't reproduce there I'll look for a honeycomb device.
(Assignee)

Comment 7

6 years ago
Created attachment 673456 [details] [diff] [review]
Patch

On pre-JB we need to take into account padding. We only have padding on large, honeycomb+ devices.
Assignee: nobody → wjohnston
Attachment #673456 - Flags: review?(sriram)
(Assignee)

Updated

6 years ago
Attachment #673456 - Flags: review?(sriram)
(Assignee)

Comment 8

6 years ago
Created attachment 673457 [details] [diff] [review]
Patch
Attachment #673456 - Attachment is obsolete: true
Attachment #673457 - Flags: review?(sriram)
Comment on attachment 673457 [details] [diff] [review]
Patch

Review of attachment 673457 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #673457 - Flags: review?(sriram) → review+
https://hg.mozilla.org/mozilla-central/rev/ea132a82593c
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Status: RESOLVED → VERIFIED
status-firefox19: --- → verified
You need to log in before you can comment on or make changes to this bug.