If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Video recording doesnt lock the screen

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: daleharvey, Assigned: daleharvey)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-basecamp:-)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Record a video for a while and the screen will go to sleep
(Assignee)

Updated

5 years ago
Assignee: nobody → dale
blocking-basecamp: --- → ?
(Assignee)

Comment 1

5 years ago
I am going to the assume the camera should just never go to sleep, even if we arent recording we are using the camera preview

Sound good?
Ouch, this got judged as basecamp-blocking- in triage (criteria are getting stricter) but this is pretty bad, hopefully there will be a patch and it will get through driver approval.
blocking-basecamp: ? → -
(Assignee)

Comment 3

5 years ago
Agreed its a blocking+, the Video app isnt high priority though, but this and the other Video gaia bugs are extremely quick fixes
(Assignee)

Comment 4

5 years ago
by "it is" I mean "it should be" :)
(Assignee)

Comment 5

5 years ago
PR sent: https://github.com/mozilla-b2g/gaia/pull/5985
(Assignee)

Comment 6

5 years ago
Created attachment 675091 [details]
Lock screen while camera is active

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Camera app is pretty much useless (goes to sleep after 30 sec)
Testing completed: 
Risk to taking this patch (and alternatives if risky): Not risky
Attachment #675091 - Flags: approval-gaia-master?(21)
(Assignee)

Updated

5 years ago
Attachment #675091 - Flags: review?(21)
Comment on attachment 675091 [details]
Lock screen while camera is active

This makes the video usable and is a pretty 2 js lines patch. a=me.
Attachment #675091 - Flags: review?(21)
Attachment #675091 - Flags: review+
Attachment #675091 - Flags: approval-gaia-master?(21)
Attachment #675091 - Flags: approval-gaia-master+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Verified able to video record for 5+min without the screen saver coming on, tested on the 11/28 unagi build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.