Closed Bug 802614 Opened 12 years ago Closed 12 years ago

[Apps] Notify user of app download failure due to connection error

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P1)

defect

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
B2G C1 (to 19nov)
blocking-basecamp +

People

(Reporter: benfrancis, Assigned: benfrancis)

References

()

Details

(Keywords: feature, Whiteboard: [LOE:S][label:story])

Attachments

(1 file)

As a user, once I confirm an app's installation, if that app requires a download in order to complete installation, and that download subsequently fails due to a connection error (whether caused by system or user), I want to be informed of that failure, so that I am aware that the installation failed to complete, understand why, and have a sense of how to fix the problem.
AppInstall-017
blocking-basecamp: --- → ?
Remaining required feature work listed at http://j.mp/VWpueM is now blocking+ to ensure visibility and tracking, per drivers' decision.
blocking-basecamp: ? → +
Priority: -- → P1
QA Contact: jsmith
We're marking this bug with the C1 milestone since it follows the criteria of "unfinished feature work" (see https://etherpad.mozilla.org/b2g-convergence-schedule).

If this work is not finished by Nov19, this bug will need an exception and will be called out at the upcoming Exec Review.
Target Milestone: --- → B2G C1 (to 19nov)
Keywords: feature
Component: Gaia → Gaia::Apps Management
Depends on: 809998
Component: Gaia::Apps Management → Gaia
Attachment #680000 - Flags: review?(etienne)
Component: Gaia → Gaia::System
Ben, as https://github.com/mozilla-b2g/gaia/pull/6345 landed, I think you should use the download error handler that came with this patch.
Comment on attachment 680000 [details] [diff] [review]
Link to Gaia patch

Please squash before merging :)
Attachment #680000 - Flags: review?(etienne) → review+
https://github.com/benfrancis/gaia/commit/ca065410f61ddfa594f6aebdcc7ab056c67797e8
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Keywords: verifyme
Keywords: verifyme
Whiteboard: [LOE:S][label:story] → [LOE:S][label:story][qa-]
Whiteboard: [LOE:S][label:story][qa-] → [LOE:S][label:story]
Keywords: verifyme
Verified with Unagi, build ID 20130103070201
User is notified about app download failure due to connection error
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: