Mouse events leak through transparent window

RESOLVED WORKSFORME

Status

()

Toolkit
XUL Widgets
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: stawel+mozilla, Unassigned)

Tracking

16 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

872.40 KB, application/x-gtar-compressed
Details
(Reporter)

Description

6 years ago
Created attachment 672310 [details]
testapp.tar.gz

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

1. run testapp (XUL app) on any OSX
2. Open any window (Finder, another firefox window) behind the testapp 
window from step 1, so that the 2nd window's scrollbar is visible but the 
rest is obscured
3. Scroll the animated GIF in testapp using the trackpad scroll gesture


The testapp window style is set to:
style="background:transparent; -moz-appearance:none;"
The content of the app needs to be redrawn.



Actual results:

occasionally the obscure window contents scrolls.


Expected results:

nothing
(Reporter)

Updated

6 years ago
Hardware: x86 → x86_64
Did this work in previous Firefox versions ?
(Reporter)

Comment 2

6 years ago
I've tested it with xulrunner version 1.9.2, 12 and 16 with the same result.

Updated

6 years ago
Attachment #672310 - Attachment mime type: application/octet-stream → application/x-gtar-compressed
stawel, are you still seeing this problem? It's been a while since anyone looked at the issue, sorry!
Component: Untriaged → XUL Widgets
Flags: needinfo?(stawel+mozilla)
Product: Firefox → Toolkit

Comment 4

5 years ago
Thank you Liz for your response, I've tested this again with "Mozilla Firefox 24.0" and it seems that the problem is gone
Flags: needinfo?(stawel+mozilla)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.