If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

JPEG image not viewable

VERIFIED INVALID

Status

()

Core
ImageLib
VERIFIED INVALID
17 years ago
16 years ago

People

(Reporter: jay garcia, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Win98SE Moz Build 2001051004

JPEG image does not download/not viewable even after downloading the image to 
local drive and attempting to open. Image displays ok in Communicator whether 
local or via URL.

Comment 1

17 years ago
confirmed witn win32 mozilla build 051104. over to imagelib
Assignee: asa → pavlov
Component: Browser-General → ImageLib
QA Contact: doronr → tpreston

Comment 2

17 years ago
When I tried to view it, my software said "Bogus Huffman table definition."

I suspect a corrupt image.
(Reporter)

Comment 3

17 years ago
It views ok in Communicator 4.77, PaintShopPro and Photoshop.

Comment 4

17 years ago
But not in any Linux product using the IJG libjpeg library.

Comment 5

17 years ago
Adding Tom Lane to the CC list.  JPEG works fine with the old IJG code in
4.x, but not with the current version.

Comment 6

17 years ago
The file is in fact corrupt, but in a way that is not detected by IJG releases
prior to 6b: the chroma-component Huffman tables describe an impossible Huffman
code.  We used to not check the Huffman tables for validity, with bad results if
the tables were bogus (anywhere from no visible problem, as in this case, up to
coredump).  I would be moderately interested to know which version of what
software generated this image --- the overall marker layout certainly looks like
IJG output, but I have no records of any of our releases having emitted broken
Huffman tables.

Anyway, as far as Mozilla is concerned, I recommend resolving this report as "no
bug".  The only reason this image is viewable by those other browsers is that
they are using obsolete versions of the IJG decoder.

Comment 7

17 years ago
Marking invalid based on Tom's comments.

Reporter, do you know what was used to create that image?
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

17 years ago
Awaiting a report from the image creator.
(Reporter)

Comment 9

17 years ago
Here is the response from the site author:

  'die jpgs werden mit dem unix "convert" erzeugt'

I have checked and find that 'unix "convert"' is a unix based utility used to 
convert one encoding to another. He does not mention which version of the Unix 
tool he is using or which encodings are involved.

Comment 10

17 years ago
Hmm.  The only "Unix 'convert'" I can think of is the convert program from the
ImageMagick package.  But ImageMagick uses the IJG library for encoding JPEGs. 
(At least in recent releases ... I have a vague recollection that Cristy may
have used some homebrew code years ago, but I doubt it would have had any
Huffman-optimization capability.)  Curious.  Could you ask him which version of
convert?  (And press him to update to a non-broken version ;-))

Comment 11

16 years ago
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.