Firefox not updating to version 16

RESOLVED INVALID

Status

()

Toolkit
Application Update
--
major
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: VanillaMozilla, Unassigned)

Tracking

15 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
My two Windows machines still have not updated from version 15.0.1. Both are set to update automatically.  File dates (e.g., 'updates.xml') show no update activity since August or early September.  

Firefox does not attempt to check for updates automatically, either from an administrative account or a limited account.  I installed the mozilla-maintenance service (and left background service enabled by default), and it still does not check for updates.

This is recent behavior.  It may be new behavior with version 15.0.1, although I may have prompted updates with Help>About on some previous versions.  I will refrain from updating manually for a few days, to preserve evidence.

There is one factor that may be slightly unusual:  Firefox is installed in E:\ProgramFiles, not "C:\Program Files".
(Reporter)

Comment 1

5 years ago
This bug was confirmed automatically, but I'm going to mark it as unconfirmed.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Updates to 16.0.1 are currently 'throttled', meaning the checks for updates Firefox initiates won't receive that update yet. This is a normal part of our release process where we allow a proportion of the userbase to update and wait for adverse feedback. A manually initiated update check would find 16.0.1 (ie if you went to Help > About Firefox), but I suggest you don't do that yet.

The file dates on updates.xml are normal given 15.0.1 shipped in early September, and the service doesn't do the checking so shouldn't be a factor here. It's unlikely that the E:\ install dir is a problem either.

To verify that Firefox is checking for updates you can do this:
* go to about:config, filter on app.update
* set app.update.log to true
* right click on app.update.lastUpdateTime.background-update-timer, and use 'Copy Value'. Report that value by pasting it into a comment on the bug
* right click on app.update.lastUpdateTime.background-update-timer, and choose 'Reset'
* restart Firefox
* open the Error Console by going Tools > Web Developer > Error Console
* filter on Messages
* wait a few minutes
* look for a message starting with 'AUS:SVC Checker:checkForUpdates'
(Reporter)

Comment 3

5 years ago
app.update.lastUpdateTime.background-update-timer 1350570593

Partial listing of messages:
AUS:SVC Checker:checkForUpdates - sending request to: https://aus3.mozilla.org/update/3/Firefox/15.0.1/20120905151427/WINNT_x86-msvc/en-US/release/Windows_NT%205.1.3.0%20(x86)/default/default/update.xml

AUS:SVC Checker:onProgress - 42/42

AUS:SVC Checker:onLoad - request completed downloading document

AUS:SVC Checker:onLoad - number of updates available: 0


Sorry, didn't realize it's still throttled, since it's been out for quite some time and I've had it on Linux.  Marking INVALID for now.  I hate it when that happens.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Updates to 16.0.1 are now unthrottled, so background checks will start the update process. Thanks for filing the bug.
You need to log in before you can comment on or make changes to this bug.