Wrap manifests lazily in DOMApplication objects

RESOLVED FIXED in Firefox 18

Status

defect
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: fabrice, Assigned: fabrice)

Tracking

Other Branch
mozilla19
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking-basecamp:-, firefox18 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

7 years ago
Posted patch patchSplinter Review
No description provided.
Attachment #672429 - Flags: review?(philipp)
Attachment #672429 - Flags: review?(philipp) → review+
Assignee

Updated

7 years ago
Assignee: nobody → fabrice
blocking-basecamp: --- → ?
Not blocking on this, but the perf improvements seems worth taking.
blocking-basecamp: ? → -
Assignee

Comment 2

7 years ago
Comment on attachment 672429 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Worst startup time.
Testing completed (on m-c, etc.): Yes, passes webapps tests.
Risk to taking this patch (and alternatives if risky): None
String or UUID changes made by this patch: None
Attachment #672429 - Flags: approval-mozilla-aurora?
Comment on attachment 672429 [details] [diff] [review]
patch

Perf win with negligible risk, even if this isn't blocking-basecamp. Pre-approving for Aurora, to land after landing on m-c.
Attachment #672429 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/47a36175f4a5
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.